MR2 Owners Club Forum banner

1 - 12 of 12 Posts

·
They call me LUCKY!
Joined
·
4,923 Posts
wow that was a "freash" question but gald you found it
 

·
Registered
Joined
·
904 Posts
serious....i had an amp installed...took a while..the installer finally came to ask me where the battery was. Even had people ask me where the engine was because they saw me open the frunk and trunk....and realized there was no engine in front or back


-Ben
 

·
Registered
Joined
·
4,033 Posts
krazzyyo said:
serious....i had an amp installed...took a while..the installer finally came to ask me where the battery was. Even had people ask me where the engine was because they saw me open the frunk and trunk....and realized there was no engine in front or back


-Ben
That happened to me at the last autocross I was at. I finished my last run and had to the 'work' for the next heat so before going on the track I wanted to load up my car. I had the hood open and the trunk open and was putting stuff in. These two highschool kids came up and I saw them look at the front with a puzzled look. They walked around back and still saw no engine and the one said there is no engine.

So finally they asked about my short shifter, so I reached in and opened the engine lid and said since you couldn't find it, here it is.

And for the battery. The first time mine died it took me a good 15 minutes to find it. Looked under the hood and didn't see it. Looked in the trunk, nothing. Looked in engine bay although I didn't think it was there... nothing.

So I finally took the spare tire out and there it was! :)
 
1 - 12 of 12 Posts
Top