MR2 Owners Club Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
1,034 Posts
Discussion Starter · #1 ·
well i took it off in November, and about every week i would go and start it but if i waited too long it would need a jump to get started. it would always start with a jump though. i jumped it yesterday and i just figured it would just start it every day. but it wouldn't start today, wasn't even trying to turn over.

The only problems ive ever had with my car in the 2.5 years is a mis-spaced spark plug and it needed a new battery. it has about 40000 miles on it.
 

·
Registered
Joined
·
1,034 Posts
Discussion Starter · #3 ·
well today i didn't use a jump, i figured it would start because it has only been a day of sitting. i put a trickal charger on there but that doesn't seem to be doing the trick.

If the car still starts with a jump could it still be a starter problem?
 

·
Premium Member
Joined
·
22,915 Posts
Odds are the battery is drained. If you are storing the car you really should invest in a trickle charger. It will save you from having to keep jumping the car after it sits for a while.

What happened was there was some sort of draw off the battery as it was sitting, running the battery down. You would jump start it and let the car run and then shut it off but never stuck a charger on it to fully charge the battery. That creates whats called a "memory" for the battery and will cause the battery not to be able to hold a charge thus leading to a new battery being needed.

You may be able to try to recharge the battery and in fact it may not be ruined if the battery is new enough. Try putting a charger on the battery for about 4 or 5 hours to get a full charge and it should retain a charge. I would strongly suggest a trickle charger though unless you like spending $60 every spring on a new battery. ;)
 

·
Registered
Joined
·
1,034 Posts
Discussion Starter · #6 ·
$m0k3 said:
well today i didn't use a jump, i figured it would start because it has only been a day of sitting. i put a trickal charger on there but that doesn't seem to be doing the trick.
ive had a trickal charger on it for like 3 weeks, i just dont think its working properly. i hook it up normally the light is red but it suppose to be green or something. but after like a week it never went green? shouldn't take more then a day.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top