MR2 Owners Club Forum banner
1 - 19 of 19 Posts

·
Registered
Joined
·
173 Posts
Discussion Starter · #1 ·
That was a steal from the xbox 360 red ring of death.

Anway, I got in my car this morning to go to work. I started it and looked down at my gauges. Everything was fine. I look farther down to the error lights and notice that my Brake! light, Charge light, and Cooling Fan light are on. This has happened to me before and it was a broken drive belt. So, I figure it happened again. I turn the 2 off, pop the engine hood, and look inside. Both belts are there. I crank it up and look at them again. Everything seems to be working. The belts are definitley there and the pulleys are definitley moving with them from what I can tell with a quick glance at 8 am before rushing off to work.

My question is: what else could be wrong? Could it be an eletrical malfunction? Could one or more of my pulleys be seized and just seem to be spinning?

All thoughts are appreciated.

-Matt
 

·
Registered
Joined
·
173 Posts
Discussion Starter · #4 · (Edited)
Papo J said:
That normally indicates that the alternator or voltage regulator are bad.

I knew there was a question I left out. That was one of my other thoughts. I guess I'll be going to Toyota today to get an alternator. Thanks for the quick reponses.

edit: Is the voltage regulator something inside the alternator or is it something else entirely? If it is, where is it?
 

·
Registered
Joined
·
173 Posts
Discussion Starter · #6 ·
ericisthereason said:
it's inside the alternator if you have an NA outside if its supercharged.
I have an NA. So I guess that I need to replace the alternator either way. I don't really feel like rebuilding it just for the regulator.

Thanks for the info.
 

·
Registered
Joined
·
253 Posts
you should get the alternator tested to be sure. I dont know where you live but Autozone usually will test it for free. Takes like 30 seconds.
 

·
Registered
Joined
·
6,218 Posts
you could dismantle and replace the worn and now shortened brushes(if that's the fault) for about 3 bux if you're being cheap...need a soldering iron
 

·
Registered
Joined
·
257 Posts
With mine,I tried to save a few bucks,yanked out the alternator,took it apart,replaced the voltage regulator,installed it again,lights still on,replaced thealternator,everything's fine,never again
 

·
Registered
Joined
·
973 Posts
at least get the alternator tested! Don't be a parts replacer lol, that cost a lot of money. It could be the connector going into the alternator, or a corroded wire.
 

·
Registered
Joined
·
6,218 Posts
if you dismantle and see that the brushes have shortened(they're wear items and the bgb shows how to replace) then that's the likely culprit
 

·
Premium Member
Joined
·
12,296 Posts
At least look at it. If the charging wire comes off, it will show the same thing. Also possible if the plug has bad contact.
 

·
Registered
Joined
·
1,642 Posts
I'm having this same problem, except it wont idle. It also bounces back and forth if I hold the gas steady in say ... 3000 RPMS.

And the lights will flash on and off ... they're off if I let go of the gas and coast but they come on when I have it in gear and give it gas.

Ideas?
 

·
Registered
Joined
·
1,883 Posts
check your altenator bracket bolts first!!! if they are loose it will cause the same ourcome of the warning lights. check all grounds and everything else you can first. buying a toyota altenator is like buying a house. HUGE commitment.

this reply goes to anyone having 3 warning light issues.
 

·
Registered
Joined
·
435 Posts
bluemister2 said:
check your altenator bracket bolts first!!! if they are loose it will cause the same ourcome of the warning lights. check all grounds and everything else you can first. buying a toyota altenator is like buying a house. HUGE commitment.

this reply goes to anyone having 3 warning light issues.
Thats exactly what happened to me and after putting the bolt in I went and returned the new alt to Checker. Got the SS bolt from a friend- cost $0

An Autozone/Checker/Kragen alt goes for about $70 after core

Its amazing that the bolt can fall out and the alt doesnt fall out with it- but I hear about that happening all the time
 
1 - 19 of 19 Posts
Top