MR2 Owners Club Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
287 Posts
Discussion Starter #1
Hey all i've got 2 turbo mr2s now...

I had a redone and got a white one not too long ago.


white one needs alot of work though.
I bought it from a guy that said it was running with stutering problem. and about 8 month ago it just stoped working after alternator belt riped off.

He said he thinks it doesn't run due to bad AFM. I tried putting AFM from a good car and it still don't work..

The engine turns over like it's about to start but it doesn't, I took old gas out and put some 93 in it.

I took off the timing belt cover and timing belt was very loose like u can slide it off and then back on.

I am thinking maybe it doesn't start due to timing belt?

I'd really like to hear some of your opinions.
Thanks.
 

·
Registered
Joined
·
300 Posts
Can you (a buddy) see if the belt is moving when you crank it over? Maybe you've got a belt that's slipping (broken teeth, etc.) or a tensioner problem. Congrats on the red one---looks nice.
 

·
Registered
Joined
·
287 Posts
Discussion Starter #4
I've changed the plugs and check for spark.

emerdeux: no i don't remember if i tried but its so loose u can almost fit your finger around the belt lol.

i got the car at local shop right now. we'll see what happens.
 

·
Registered
Joined
·
672 Posts
id go with the timing belt issue first, you SHOULD NOT be able to slip the t-belt off and on without a lot of effort.

and the stuttering can be anything from a boost leak to plug wires.

t.belt with tensioner first. diag from there
 

·
Registered
Joined
·
287 Posts
Discussion Starter #6
yep thats exactly wat i am doing now and i also think that previous owner might have had problems with stuttering due to timing not being correct you know?
 

·
Registered
Joined
·
672 Posts
i know, i love when a car comes in to the shop............."i think its the battery/or starter"

and when you crank it.

theres no compression!!!!!!!!!!

not making fun of you, but "the previous driver"

seriously, not making fun of you
sincerely
 

·
Registered
Joined
·
287 Posts
Discussion Starter #9
guys from shop called today, said that my t-belt tensioner fell apart and idle pulley is bad and waterpump can use a change. all in all i asked him ho wmuch for work he siad 300 for work... does that sound like a good deal?
 

·
Registered
Joined
·
287 Posts
Discussion Starter #11
that was at the dealership. i took it to small shop. i mean like for a small shop is that a good price? or 300 for labor is too much?
 
1 - 11 of 11 Posts
Top