MR2 Owners Club Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
467 Posts
Discussion Starter #1
As the title says, I have this clunking coming from the rear passenger side when I go over bumps or when I'm driving over 75mph. I'm pretty sure it's a component of the suspension, but I don't know exactly what it would be. Isn't it called the bump stop or something that might be worn out? The shocks themselves aren't worn out so at least I have it narrowed down a bit.
 

·
Registered
Joined
·
192 Posts
check worn out bushings as well. i had that same problem and i thought it was coming from a worn out shock/strut. after further investigation, the problem was just a worn control arm bushing. good luck to you
 

·
Registered
Joined
·
1,211 Posts
xturfoz said:
It can be the gland nut as I once had that issue. Re-check and re-tight the nut on top of the shock.
did you have a lot of oil spilling out from the loosened gland nut during the time of the problem? or did it just seep out a bit ?
 

·
Registered
Joined
·
1,211 Posts
thanks.

i'll have to check it out. the vise i was using to tighten the gland nut was loose so i was a bit unsure on this particular strut. i think i can tighten it a few more turns with that big ol plumbers wrench.
 

·
Registered
Joined
·
3,087 Posts
mrazntre said:
thanks.

i'll have to check it out. the vise i was using to tighten the gland nut was loose so i was a bit unsure on this particular strut. i think i can tighten it a few more turns with that big ol plumbers wrench.

for me i had to take the whole strut out and re-compress the shocks to have mine tighten.
 

·
Registered
Joined
·
415 Posts
i had that problem on bumps and the clunk was my engine bouncing around because of a loose mount. I always thought it was the suspension tho.
 

·
Registered
Joined
·
1,211 Posts
xturfoz said:
for me i had to take the whole strut out and re-compress the shocks to have mine tighten.
i pulled mine apart to put in some TRD springs. it was BAD. I was able to turn the gland nut by hand. *eek* good thing i read your post because i would have never thought it was the gland nut. I've been having some pretty bad luck with this car so far, but I'm glad it's all done, at least for now.

Good think the strut wasn't ruined *phew* I also swapped up to a larger rear sway bar (93+) and everything is tight again. I've never heard my car without a clunk so now i'm very happy.

thanks! :thumbup
 

·
Registered
Joined
·
3,087 Posts
mrazntre said:
i pulled mine apart to put in some TRD springs. it was BAD. I was able to turn the gland nut by hand. *eek* good thing i read your post because i would have never thought it was the gland nut. I've been having some pretty bad luck with this car so far, but I'm glad it's all done, at least for now.

Good think the strut wasn't ruined *phew* I also swapped up to a larger rear sway bar (93+) and everything is tight again. I've never heard my car without a clunk so now i'm very happy.

thanks! :thumbup
no problem man, atleast you didn't learn the hard way like i did. my rear passenger shock pretty much feel apart while i was driving cause the gland nut came loose. some how my car was able to drive for whatever that time and i got home and was like WTF why is my car slanted. jacked the car up and man, my shock was just leaning inward to the wheel wall!
 

·
Registered
Joined
·
1,211 Posts
oh man, that's terrible! I'm glad you made it out.

I'm thinking my girl put a hex on my car.

What happened to SHiFTMR2t? did you find the culprit?
 
1 - 14 of 14 Posts
Top