MR2 Owners Club Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
254 Posts
Discussion Starter #1
So my duece sat for almost a year and the other day i finally got a battery in it, started it up, went to check all the lights and the turn signals just straight up don't work. No flashing, nothing lights up and i don't here the generic *click* *click* that it usually makes. Where is the signal realy located? Any other ideas? Thank you.

-Eric
 

·
Registered
Joined
·
3,139 Posts
Fuse?
 

·
Registered
Joined
·
609 Posts
there is a fuse by the dead pedal inside the car, behind that is the flasher relay. I'm not entirely sure but there could be another indicator-related fuse in the frunk, having to do with the daytime running lights. Could be any of those.
 

·
Registered
Joined
·
1,110 Posts
Don't worry, common error, years ago in my GT4 (alltrac) i forgot to plug the hazard switch back in after a dash swap. It took me a about an hour before I realised the indicators weren't working and thought WTF.

Discovered I hadn't plugged the hazard switch back in.
 

·
Registered
Joined
·
361 Posts
Didn't know you had to have hazards plugged in to get your turn signals to work, that was crazy to find out. My dash lights don't work right now, but I don't even know where to start looking. I don't know what fuses deal with that.
 

·
Registered
Joined
·
254 Posts
Discussion Starter #11
so sure enough, pulled the cover off today and the hazard button wasn't plugged in. hooked it up and everything works fine now. thanks.

-eric
 

·
Registered
Joined
·
322 Posts
also remember if the hazerd switch has a bent prong.... it will cause that same affect.... so always check that when you are playing in that area before you replug everything
 

·
Registered
Joined
·
2,684 Posts
plur said:
Didn't know you had to have hazards plugged in to get your turn signals to work, that was crazy to find out. My dash lights don't work right now, but I don't even know where to start looking. I don't know what fuses deal with that.
Is the dimmer plugged in?
 

·
Registered
Joined
·
14 Posts
The whole turn signal circuits run though the hazard switch so as we see here, if it's unplugged nothing works. I had this same issue on a Subaru.
Lol, kicking myself for not checking the forum first. Instead, I just purchased a relay and additional fuses, smh.
 
1 - 17 of 17 Posts
Top