MR2 Owners Club Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi thanks in advance for your help, I have an issue with my UK mr2 na sw20 as the title says I'm not getting any spark coming after the distributor but got spark going to it its cranking getting fuel but not firing also the check engine light isn't coming on with the ignition also has started to get a squeal when turning the car over which wasn't there before. A quick low down of the events leading to the issue. I replaced the distributor cap and rotor arm due to the old one needing replacing but unfortunately the old bolts sheered off so couldn't fit new bolts due to not having access to a drill and the garages being closed due to covid19 I used a few cable ties and a little bit off sealent to make it secure ran with no issues for a few weeks then when driving to go to the garage to get it fixed properly when the car just died and stopped like it had no power but all electrics still working radio lights ect tried to start it a few times but no luck call the recovery company to take me to a garage turns out my quick fix on the distributor cap failed and the rotor arm was rubbing on the cap melting the plastic and finally putting a hole it to bottom of the cap so have replaced them checked the distributor which seems OK but still not getting any spark any advice would be appreciated thanks

Keith
 

·
Premium Member
Joined
·
11,975 Posts
Do you have a spark from the coil, or not? If you have a spark from the coil wire but none at the plugs, then you messed up your distributor, and you need to figure out what you did to it. It is that simple. If you have no spark at all, then I suggest that you check fuses and connections. No CEL suggests that your ECU is not getting power. If it is getting power, then fixing the CEL is a good idea. It may be trying to tell you what the problem is.
 

·
Banned
Joined
·
9 Posts
no fuel, no sparkle, and no check motor light at all ? have you verified whether some way or another you lost capacity to the ecu from something you did while migrating the wire box ? on the off chance that so begin finding the work you did to move the circuit box. that is the thing that it seems like since you have no check motor light. which is assume to come on when the key gets turned on before wrenching.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
no fuel, no sparkle, and no check motor light at all ? have you verified whether some way or another you lost capacity to the ecu from something you did while migrating the wire box ? on the off chance that so begin finding the work you did to move the circuit box. that is the thing that it seems like since you have no check motor light. which is assume to come on when the key gets turned on before wrenching.
Sorry for the late response the car is getting spark to the dizzy but not passing through I have replaced the dizzy with a completely brand new one and still not getting any spark at the plugs managed to the the check engine light to come back on so ecu isn't the issue. My mechanic is really stumped as to what the issue is parts replaced so far are coil pack, king lead, dizzy complete, leads, plugs fuses but still no joy costing a small fortune any advice is greatly appreciated thank you
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
Sorry for the late response the car is getting spark to the dizzy but not passing through I have replaced the dizzy with a completely brand new one and still not getting any spark at the plugs managed to the the check engine light to come back on so ecu isn't the issue. My mechanic is really stumped as to what the issue is parts replaced so far are coil pack, king lead, dizzy complete, leads, plugs fuses but still no joy costing a small fortune any advice is greatly appreciated thank you
 
1 - 5 of 5 Posts
Top