MR2 Owners Club Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
When I put the key in the ignition and turn it there is nothing no lights except for a battery light however i have tested the battery and it;s good, is used to ;ower my other car. However the headlights turn on no issue. No dashlights apart from a battery light. Any suggestions?
 

·
Registered
Joined
·
8 Posts
Discussion Starter #2
Now the lights turn on to signal a door is open aswell as the red lights under the doors.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #4
Page 48 in this link will give you the power source diagram. Have you checked all your fuses?
thanks, so I went through the fuses there was a 7.5 amp blown, a 15 amp and a 120 amp, and replaced them all. Now there are dashboard lights which is progress but when I turn the key to on not start (start the engine) there are 2 tick sounds coming from the front by the fuse box and when i turn the key further to start the engine there is obviously no start. I replaced the EFI relay and no change. Tomorrow i can try a new ignition fuse from the engine bay. Any ideas?
 

·
Registered
Joined
·
2,068 Posts
thanks, so I went through the fuses there was a 7.5 amp blown, a 15 amp and a 120 amp, and replaced them all. Now there are dashboard lights which is progress but when I turn the key to on not start (start the engine) there are 2 tick sounds coming from the front by the fuse box and when i turn the key further to start the engine there is obviously no start. I replaced the EFI relay and no change. Tomorrow i can try a new ignition fuse from the engine bay. Any ideas?
Which fuses were the 7.5 and 15amp?
Do you know why the 120amp fuse blew? Touched the alternator wire to the chassis or similar accidentally?

Asking questions as it's very hard to diagnose electrical issues over the internet with limited information. I'll probably ask you to test things with multimeter at some point.

I'm not too sure what the ticking in the front would be but there are a few relays in the front fuse box which could be it.

The only fuse stopping the starter motor from turning over is the 7.5AM2 fuse. Other than that if there are any issues with other fuses then we can look else where.
 
1 - 5 of 5 Posts
Top