MR2 Owners Club Forum banner
1 - 5 of 5 Posts

·
Registered
'91 Turbo with a JDM '93 swap
Joined
·
221 Posts
Discussion Starter · #1 ·
Alright, now that the thing is quiet and I'm more emotionally invested I figure it's time to ask.

My 93 jdm gen 2 swapped 91 has a cold idle of about 500-600 and it has a bit of a miss, smells a bit rich too.

It's running a 91 ECU with a harness to adapt the different pinout of the93 harness
No vacuum leaks.

It will do this even with a 91 USDM ecu.

Runs and drives fine otherwise. When warm, idle is about 950.

Any ideas as to where I should start?
 

·
Registered
Joined
·
7,852 Posts
Yes, follow BGB electrical checks to test. Most of time it’s a mechanical issue which needs freeing up of the valve due to corrosion.

Not really hard to rebuild and test on bench and if careful gaskets won’t be required. Apart from coolant port position it’s the same design as earlier models. Mine is a 98GT and I used parts from a 91NA.

Can check TPS at same time as this can also produce a missfire from having a dead spot on transducer. Just use your meter to test over full range according to BGB procedure.

jimb
 

·
Registered
Joined
·
4,345 Posts
Possibly unplug the cold start injector electrical plug. Injector might be leaking. Worth seeing how it idles after.

The iacv isn't too hard to clean. Hardest part is freeing the Robertson screws. Spray with Pb blaster and press hard on the head when freeing. Maybe even tap with hammer first.
 
1 - 5 of 5 Posts
Top