MR2 Owners Club Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
346 Posts
Discussion Starter · #1 ·
One more giant leap for Roykind. I hooked my MegaSquirt board up to the stim and a laptop today and started playing. So far all is good.

One question though. When using the RPMF and RPMC pots on the stim it didn't react as expected. I had to turn the RPMC pot to about the 3/4 point before I saw any RPM signal at all on the Megatune screen. At that point the RPMF pot can swing the RPM from about 800 to well over redline. This is with the default 8cyl setup. I expected the RPMC control to get me to within say a 2000 rpm window and the RPMF control to get me to the various 500rpm points in between. I checked over the resistance of the rpm pots singly and combined as well as checked the output frequency and all seems to be in order.
 

·
Registered
Joined
·
1,219 Posts
That's how mine worked. Don't believe it's a problem. They're supposed to be coarse and fine controls (c&F). I was a little confused by their reaction, as well.

James
 

·
Registered
Joined
·
346 Posts
Discussion Starter · #3 ·
Thanks James.

I had pretty much convinced myself that it was normal operation after thinking about the frequency range that has to be covered in order to test all configurations.

Twelve thousand rpm for a single cylinder engine is equivalent to a thousand rpm for a twelve cylinder engine frequency wise. That's a huge range to cover.
 

·
Registered
Joined
·
821 Posts
Confirmed-- that's working how it's supposed to. Also one of the temp POTs, I think it's IAT, will jump to a pretty high number if you crank it all the way up, then drop back down to like 170 all at once. That's normal operation as well.

So are you using 'The Jamesl Method for MegaSquirting your MKI MR2'? It's highly recommended ya know ;)
 

·
Registered
Joined
·
346 Posts
Discussion Starter · #5 ·
It's been the plan all along. We both got the same idea looking at the ignition system documentation along with the development of MegasquirtnSpark. James is a whole lot less lazy than me and has ended up being the test dummy, for which I'm very thankful.

I've got an hks tubo kit in boxes but it's not getting anywhere near my motor until I've got the fuel and ignition worked out. I learned the hard way on my previous 2 and ended blowing my motor, twice. Stupid hks f-con. Closed proprietary systems suck.
 
1 - 5 of 5 Posts
Top