MR2 Owners Club Forum banner

1 - 9 of 9 Posts

·
Crazy OEM nut.
Joined
·
7,328 Posts
Discussion Starter #1
I never even thought about it until recently, but does the NA gauge cluster even have the spot for the foglight indicator on the gauge cluster, like the turbo models do?

My NA has fogs on it, but it doesn't light anything on the dash, so I'm wondering...is there not a space for it, or does mine simply not have a bulb in it to light up?

-Nathan
 

·
Crazy OEM nut.
Joined
·
7,328 Posts
Discussion Starter #3
Seth W said:
http://www.mr2-tech.com/bgb/mechanical/volume2/body_electrical_system.htm
look in combo meter and or lighting
http://www.mr2-tech.com/bgb/mechanical/index_mechanical.htm in general is a good thing to bookmark. I'm not a wireing expert but you could probibly wire it another indicator light if it doesnt have one seperate, so I guess that sort of helps?
Of course a light could be made to light up, but I'm asking if there is even the little cut-out with green tint, like the turbo gauge cluster that could indicate that they are on.

The best I could do was to flash a flash light directly at the left hand side of the cluster, but I still couldn't make out even the indicators I know are there.

-Nathan
 

·
Crazy OEM nut.
Joined
·
7,328 Posts
Discussion Starter #5
MISTER2 said:
My MR2 Turbo came with factory foglights...but there is no light on the gauge cluster?

:confused:
That's weird, my 93T had a light on the dash (in the gauge cluster).

-Nathan
 

·
Premium Member
Joined
·
14,333 Posts
Both of my 93NAs have lights on the dash cluster. I have fogs installed on both of them. They were also both pre-wired for fogs.
 

·
Crazy OEM nut.
Joined
·
7,328 Posts
Discussion Starter #9
Well, I just took my gauge cluster out to sort of look at it and play with it. Mine does not have the tinted cutout for the foglight, BUT, when I put a bulb into the slot behind where the indicator should be, it does turn on the bulb when the foglights are turned on. So... I just need to find someone selling a turbo gauge cluster and swap out the little black panel that has the dummy lights on the left side.

Oh, and this gauge cluster does have the tinted cut out for the engine bay fan, but without a bulb and it wasn't even opened for a bulb. Good thing to know, and hopefully I can get it to work once my German engine bay fan arrives, and I hook everything up.

-Nathan
 
1 - 9 of 9 Posts
Top