MR2 Owners Club Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
166 Posts
Discussion Starter #1
O
M
F
G

was coming home from work, noticed some smoke coming out the engine vents...

thought "hmm ill pull over at the gas station like 1km down the road"

lift the lid and theres oil all over the engine bay and FLAMES all over my headers!

run into the station "um hai. can i borrow a fire extinguisher? my car is burning"

put the fire out, and realise if just sprayed foamy water all over my exposed sparkplug gallery

now i HAVE to do what id planned to do anyway, which is drain the oil, take off the sump unclog the strainer/pickup, re silicone it back on, take off the cam covers, clean them up, replace the gaskets, reattach the valve covers, take all the water out of the sparks, and clean the f##k out of my engine bay.

ill also have to find a replacement oil filler cap, seeing as mine has gone AWOL

_______ this week bites

*sigh*
 

·
Registered
Joined
·
89 Posts
hehe , "dissapeared" as in did you forget to put it back on when you have changed oil or something like that , quite strange that is just falls off , but still , that sucks ...
 

·
Registered
Joined
·
562 Posts
Wow thats a big mess. That same thing happend to my friend in Ottawa. Toyota didn't put the cap on at all. He had alot of smoke but no fire. He was on the highway and all oil came out of the engine lid and all over the back of the car. His car was red and pretty much mint. It took alot of polishing and buffing to get the the color back. It looked pink before he had it detailed.
 

·
Registered
Joined
·
166 Posts
Discussion Starter #8
i think i may not have fully tightened it last time i topped up the oil, and its slowly worked loose. either way :(
 

·
Registered
Joined
·
3,846 Posts
Actually doesnt look too bad.. cant really see any evidence of a fire.. hopefully after you clean everything up it'll be fine..

Goodluck

Brando
 
1 - 13 of 13 Posts
Top