MR2 Owners Club Forum banner
1 - 6 of 6 Posts

·
Premium Member
Joined
·
5,210 Posts
Discussion Starter · #1 ·
Im interested in doing this. I currently have one walbro installed, and i have been searching for info/pics/how-to's on doing this modification.

What all needs to be done to the tank? Does anyone have install pics?

Any help would be appreciated :)

-Ty
 

·
TD06 HP record holder
Joined
·
3,636 Posts
We have done it twice now I will try get some pics. Everything Brian did was great but we did the drain different instead of welding a fitting in the tank we just put another bulk head fitting next to the other one and set the return in there.
 

·
Premium Member
Joined
·
5,210 Posts
Discussion Starter · #4 ·
1fastsol said:
We have done it twice now I will try get some pics. Everything Brian did was great but we did the drain different instead of welding a fitting in the tank we just put another bulk head fitting next to the other one and set the return in there.
yeah, i was going to try to do it that way as well. Is the install pretty straight forward? How did you wire the 2nd pump?

-Ty
 

·
Registered
Joined
·
2,641 Posts
We are working on a kit for this as well. Hyde will be the first test run. If it goes well, I will start selling it. Here are some teasor pics. It is just really tough to get the pickup socks to fit into the stock baffle. Not to mention some filing on the tank... The thing is that I am not really convinced that we can offer this kit for much less than the Large HP Kit that uses an Aermotive Kit that we already offer Here . The thing is that having two pumps is not as reliable as one. If one goes out, you will have some fuel, your fuel pressure will drop, and then bad things will happen... We just want to see how it works out on Hyde...








Take it easy,
 

·
Registered
Joined
·
2,097 Posts
i did it my way ...

zipped them together on un-equal heights , and i whas able to push them '' easy '' through the existing hole. than i pushed it right next to the other with a large screwdriver :D

i didnt use 2 seperate lines either , just 2 stock lines ( in tank ) than an Y-connector with 2 x 7mm in , and 10mm straight out. ,and hooked it up to a new elbow connector on top of the tank , from there i'm running a 10mm ( inner size hose !!) to the filter , and than a 10mm hose to the fuel rail . i'm still using a stock size retour line.

for the wiring i just split the existing wiring , not sure if this will work but my car idles on it , if the resistor pack jumps to 12v i might burn my fuses. but i did it just for a test.

anyway hope this helps a bit.
.... aggain , not sure if this is the way to go , but i whas the most easy way for now. :D


good luck buddy !

Best Regards :
Peter
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top