MR2 Owners Club Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
79 Posts
Discussion Starter #1 (Edited)
my mr2 boost 14psi on the stock turbo, and holds that pressure and does not leak.

but my car will blow off if i hold the boost at 5 psi and then rebost, blow off,, etc... so i causes the car to shake but if i boost through it theres no prob.

its not the blow off, before everyone tells me to tighten it and all my mechanics are stumped on whats happening

does anyone have this prob, and how can i fix it?
i have tried everything? but still open to suggestions

i have an apexi blow off

ignore this, look down about 3 posts there's a better description down there
 

·
Registered
Joined
·
6,985 Posts
I am not exactly sure what you are saying...:confused:

Do you have an aftermarket blow off valve?

If I am reading correctly I think you are running super rich when you lift because you are venting metered air to the atmosphere.
 

·
Banned
Joined
·
3,065 Posts
it sounds like you have a blowoff valve vented to atmosphere. just get a stock one...i don't understand how people can drive around with that annoying ass pssssh sound all day.
 

·
Registered
Joined
·
79 Posts
Discussion Starter #5
what i am trying to say is

if i hold the boost at 5 psi the blow off will expel waste, and then re-hold the boost on and off.

but if i boost through 5psi to 14psi it does not blow off. and the pressure does not leak off.

i also know that if i convert it back to stock the problem might got away,

so does anyone know how to exterminate the problem.

keep in mind that this is a track car, so no b.s. street racing ideas that envolve zip ties
 
1 - 7 of 7 Posts
Top