MR2 Owners Club Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Can someone help me out with an emissions MOT fail? 94 Rev 2, I swapped the O2 sensor recently, putting it all back together the exhaust has started blowing from the flex tube I think so I've order a new one. Garage say the failure could be because of the leak. Question is, should I swap the cat while I'm at it? Will this help?

70749
 

·
Registered
Joined
·
42 Posts
Looks like the car is running rich. Could be a bad O2 sensor. Was the one you swapped out new or used? Could also be a bad CAT, but since the Lambda is so high and the HC is passing, I'm thinking O2 sensor . . . Make sure the sensor wiring is good too; not just the sensor.

I don't think a leak from the flex pipe would cause a failure because there is no emissions equipment after it (or am i mistaken?)
 

·
Registered
Joined
·
9 Posts
Discussion Starter #4
Looks like the car is running rich. Could be a bad O2 sensor. Was the one you swapped out new or used? Could also be a bad CAT, but since the Lambda is so high and the HC is passing, I'm thinking O2 sensor . . . Make sure the sensor wiring is good too; not just the sensor.

I don't think a leak from the flex pipe would cause a failure because there is no emissions equipment after it (or am i mistaken?)
Thanks mingtauw.

The o2 sensor is after the flex pipe so I’m guessing a leak would through it out. It’s brand new. I also took the heatshields off and the pipe is peppered with holes on the way into the back box and after the cat. So my theory is it’s leaking like mad and will throw everything out. Put a new front pipe on tonight and I’ll have a go at patching up the back box pipe. Fingers crossed that will sort it!
 
1 - 5 of 5 Posts
Top