MR2 Owners Club Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1,130 Posts
Discussion Starter · #1 ·
Hey guys.
I was havin fun last night and wheni went to go do a drift my car just died all of a sudden. It will start up idle for about 3-5 seconds and then dies. It is also leaking oil very badly now. A drip of oil about every three seconds. So when i get to it on monday it will be completely empty. I think oil got into the intake system and is boggin the car down. either that or a boost pipe blew off. I didnt have enough time to look at it before the cops showed up. They were nice and called a tow truck (it was a flat bed, so i knew the front end wasnt gonna get ____ed up :) ). Any ideas? has this happened to anyone?
 

·
Registered
Joined
·
1,130 Posts
Discussion Starter · #3 ·
not that i saw. yay, that means there's no oil in the intake. It is leakin oil really bad tho. Also, after the car died, there was a weird gurgling sound comin from the turbo area, atleast that s where i think it was comin form
 

·
Registered
Joined
·
1,624 Posts
G3aR said:
not that i saw. yay, that means there's no oil in the intake. It is leakin oil really bad tho. Also, after the car died, there was a weird gurgling sound comin from the turbo area, atleast that s where i think it was comin form
Gurgling sound is always present in a mr2 turbo.
 

·
Registered
Joined
·
4,033 Posts
It could be that one of the IC pipes came loose. I had a hard time getting my Spearco IC pipes in correctly so that they will hold boost and when I would attempt to boost one of the couplers would come loose. Causing a sudden loss of power almost like applying the brakes. Afterwards it would idle rough and stall sometimes unless I gave it a little extra gas. The first time it happened sucked because I was 2 miles from the garage and at the bottom of a steep hill.
 
1 - 5 of 5 Posts
Top