MR2 Owners Club Forum banner

1 - 20 of 21 Posts

·
Registered
Joined
·
2,019 Posts
Discussion Starter #1 (Edited)
hey what's up ya...im currently doing a jspec swap and i ran into some problems...and i need some help....

ill say this first...i have a 91 mr2 turbo body..and im using a 91 jspec motor and the jspec harness...

so lastnight i got the motor to crank...but it wont catch...i noticed that my timing was off...so i re did that...it's good now....still the motor will crank but wont catch....next then i noticed that i have no spark....took my dizzy off the blown US motor and put it on the jspec motor...still no spark...next i checked the wire that comes off the top of the dizzy cap to the ignitor for spark....still i have no spark.....so no i noticed that in the trunk there is a white plug from the U.S box ( its the box on the driver side that is mounted onto the trunk firewall where a couple of white plugs from the engine wiring harness plugs into) that does not plug up to the Jspec harness....

here are some pictures..let me know if the plug is really imporant...i think it is....i think it's a signal plug from the ecu to the engine i think....let me know what i can do now....hopefully i wont have to swap harnesses...

 

·
Registered
Joined
·
2,019 Posts
Discussion Starter #2
:feedback:
 

·
Registered
Joined
·
2,019 Posts
Discussion Starter #4
Benzomr2 said:
try getting your pics to work, that would be helpful
yea...i know...the web host has been down for a couple of days....doing some upgrades...so yea..sorry about that...
 

·
Premium Member
Joined
·
2,254 Posts
What body harness are you using? I have a 93 jdm motor swap that wont spark but i am using the body harness that came with the car ('91 5sfe) and the white connector you're talking about fits fine into that harness. Have you checked out the BGB? I just recently found a "what to do if your car won't spark" list inside the BGB. I'll post it if you haven't seen it before.

I'm troubleshooting mine as well and so far I had to replace my ignition coil, check that out as the tests I was performing indicated that it was bad. Just a thought. As I go along my car and try to figure things out, I'll try to help you out too.
 

·
Weak and Poo
Joined
·
328 Posts
How many pins is the plug you are talking about?
If that plug isnt keeping it from sparking, i would go ahead and swap out the coil and igniter if you have a spare(maybe one laying around from the swap?). If not you can use an ohmmeter to do a test on the coil.

Primary coil resistance check= ohms between + and - terminals should be ~ .40-.50 ohms. (according to bgb)

Secondary coil resistance check= ohms between + and high tension terminal(the one that has a wire leading to the dizzy) should be ~ 10.0-14.0 kohms (bgb)

Hope this gives you something to do. It would really make things easier with a pic of that particular plug. good luck
 

·
Registered
Joined
·
2,019 Posts
Discussion Starter #9
picture is up.....
 

·
Registered
Joined
·
22 Posts
bump.

having the same problem. using jdm harness/ecu, getting no spark. ive been told that i should just man up and switch to the usdm harness/ecu...anyones thoughts about this?? looks like the jdm/usdm o2 sensors are different, and obviously the jdm motors make more power, most likely because of emissions??...please any input would be appreciated... :thumbup
 

·
Registered
Joined
·
2,019 Posts
Discussion Starter #11
whiteef8 said:
bump.

having the same problem. using jdm harness/ecu, getting no spark. ive been told that i should just man up and switch to the usdm harness/ecu...anyones thoughts about this?? looks like the jdm/usdm o2 sensors are different, and obviously the jdm motors make more power, most likely because of emissions??...please any input would be appreciated... :thumbup
IM USING US HARNESS AND ECU...AND STILL NO SPARK....
 

·
Weak and Poo
Joined
·
328 Posts
i rembember something about a JDM Ecu working on a US harness, but not the other way around. Anyone?

you are using the Jspec engine harness but the US body harness, right?
 

·
Registered
Joined
·
2,019 Posts
Discussion Starter #14
SW20FL said:
:dontknow: So are you using the USDM or the JDM harness?
usdm
 

·
Registered
Joined
·
2,042 Posts
http://www.mrtwo.net/mr2modproject/gen3stuff/gen3wiringdiagrams/3sgte-ecu-pin-by-coyotemr2.jpg

according to this the USDM gen II and the JDM gen II ecu pinouts are different. The JDM ECU will probably not work with the USDM harness and you probably can't use a US body harness with a JDM enigne harness.

I joined a 92 na harness to a 92 JDM gen II harness with no problems, but did it in the cab. I just cut the NA harness where the clip was cut, traced every wire, and matched them up. most matched color to color, some did not and i had a bunch extra that i didn't need. (they were for the PS, ABS and other options I didn't have)
 

·
Weak and Poo
Joined
·
328 Posts
i think it only worked for the 91,92 jdm ecu on the 91,92 USDM harness.
the pinout picture shows only the 93 jdm pins to the ecu.
 

·
Registered
Joined
·
22 Posts
up for more help, i now switched to the usdm harness, like exodus, and plan on using the us ecu as well. i still have these remaining plugs, anyone know what they are or what to do with them? i am still getting no spark, and i'm almost 100% sure these plugs are the culprit. please help!!
 

·
Registered
Joined
·
2,019 Posts
Discussion Starter #18
whiteef8 said:
i am still getting no spark, and i'm almost 100% sure these plugs are the culprit. please help!!
get a complete wiring diagram....and follow the wires....my whole problem was that i had a blown 40 amp fuse under the front hood.....
 

·
Registered
Joined
·
2 Posts
I've a problem with that whit plug too, it will fit but some wires are at the wrong spot.

Here In Holland is it difficult to find a wiring diagram about it from a turbo (Gen 2), were can i find something from a wiring diagram for that white plug?
 

·
Registered
Joined
·
2,019 Posts
Discussion Starter #20
TomMR2 said:
I've a problem with that whit plug too, it will fit but some wires are at the wrong spot.

Here In Holland is it difficult to find a wiring diagram about it from a turbo (Gen 2), were can i find something from a wiring diagram for that white plug?
www.mr2-tech.com
 
1 - 20 of 21 Posts
Top