MR2 Owners Club Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
1,542 Posts
Discussion Starter · #1 ·
My '91 only blows hot air intermittently. It seems like it'll only blow hot air while I'm actually driving, and as soon as I idle, it'll start blowing cool air. What's the cause of this? I'm planning on flushing out my coolant and making sure it's full today. Not sure if that will do anything but it should be done anyhow. Any ideas?

Thanks,
Chris
 

·
Registered
Joined
·
1,542 Posts
Discussion Starter · #3 · (Edited)
Well, what I did notice is that after the car is running, the temp gauge rises to "normal operating temp" fairly quickly... unlike my previous '91. And once the gauge reads "normal temp", it won't blow warm air for quite some time.

How is a thermostat stuck open, and how do I check/fix this?

Thanks jackstands for the quick reply.

EDIT: Does "stuck open" mean the Tstat is bad and needs to be replaced?
 

·
Registered
Joined
·
1,542 Posts
Discussion Starter · #4 ·
I did some searching and am convinced the thermostat is stuck open like you suggested. I didn't realize this was somewhat common.

How difficult is it to replace? I would like to fix it soon since it's winter and don't want to cause any damage.

All I need is the thermostat for $13 from partznet.com?

Thanks,
Chris
 

·
Registered
Joined
·
764 Posts
Is the temp needle stay in the middle of its range? If so, then the TStat is okay. If it's stays at the low portion of its range, then it's stuck open and you'll have to replace it. I haven't replaced the TStat on the MR2 but it looks to be pretty easy, pretty much like any other car. I would imagine bleeding the coolant would be the trickiest part about the MR2 coolant system.
 

·
Registered
Joined
·
764 Posts
I don't know what to tell you. If your engine is operating at normal temps, you should have heat. Is the blend valve working? When you pull the selector from hot to cold, do you feel resistance? Pop the frunk and manually work the heater control valve.
 

·
Registered
Joined
·
1,542 Posts
Discussion Starter · #8 ·
I drove today and it seemed to be working fine. I ordered a new thermostat anyhow just incase, but I'll drive around some and see if I notice any abnormalities again. ...this is my 3rd day of driving it so I'm not sure if it was just a freak accident or what.
 

·
Registered
Joined
·
1,542 Posts
Discussion Starter · #10 ·
I'll for sure check that out. I drove to school today and it did it again, but only once. So it's not a constant thing, but I wasn't imagining it and it did actually happen. I was at a red light and felt the air coming out was quite cool, and as soon as I sped off it was hot again.
 

·
Registered
Joined
·
1,542 Posts
Discussion Starter · #12 ·
so summer came around and i didn't need my heat. it's getting cold again and i noticed it again.

i had my coolant flushed at a shop, not sure if that included bleeding the heater core. anybody know?

just to recap, according to the temp gauge my engine is operating at normal temps, but when i stand still at a red light and my heat is on, cool air will be blowing until i start moving again.

i haven't replaced the t-stat, but i do have a new one laying around. haven't replaced it yet being that it should be fine as jackstands commented.

any suggestions?

thanks,
chris
 
1 - 12 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top