MR2 Owners Club Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
61 Posts
Discussion Starter · #1 ·
I have a 92 5SFE and it runs great i love the car, i just put a new distributor cap and rotor new NGK plugs and wires and adjusted the timing because it was way off wack...but when it rains it doesnt want to start, only rain or moisture though, it starts up fine on a normal day or even with a foot of snow on it, but when it rains it wont start, it cranks fine but doesnt start. I was thinking that water is getting into my distributor because it is right underneath the whole that is in the engine lid, i was wondering if anyone else has this problem, i am thinking about taking off my distributor cap and putting a bead of silicon around it and putting it back on good idea or no?
 

·
Registered
Joined
·
61 Posts
Discussion Starter · #6 ·
another question i got is if everyones engine bay is getting all wet because of that whole in the engine lid? like im trying to make my car into show quality and its kinda pointless to clean the engine if when it rains its going to ruined again
 

·
Registered
Joined
·
3,104 Posts
Timmy1288 said:
another question i got is if everyones engine bay is getting all wet because of that whole in the engine lid? like im trying to make my car into show quality and its kinda pointless to clean the engine if when it rains its going to ruined again
The only way to keep it show quality is to park it inside and not drive it in the rain.
 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top