MR2 Owners Club Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
52 Posts
Discussion Starter #1
Have a 91 turbo with gen4 swap. I have the MSD tach adapter and my tach moves but only about 1/4 of actual rpm. I took apart the cluster to have a look at the capacitors.

Do these tach capacitors look OK?







What are these capacitors for? Look like they've puked.



Also, is there a way to get the mechanical speedo working?

Sent from my SM-G965U using Tapatalk
 

·
Registered
Joined
·
1,506 Posts
Capacitors might look ok but they can dry out. Best replace the ones on the tacho. Also, using the MSD is not a great way to get the tacho working. A 10k resistor on the tacho is better. This replaces one that's already there.

The other capacitors look like that is just glue. I forget what that board does.

For the Speedo, what was changed in the car for the original gearbox and Speedo sender?
 

·
Registered
Joined
·
52 Posts
Discussion Starter #3
I bought the car already swapped but looks like original e153 and speed sensor. I guess I need to replace the cables but haven't found a source with new ones. I guess my question would of been better asked on where to find new cables...

As for the tach resistors can you point me in the right direction to find the exact ones that need to be replaced and specs on replacement ones? I've searched and haven't found anything very specific or simplified.



Sent from my SM-G965U using Tapatalk
 

·
Registered
Joined
·
1,506 Posts
Credit to the original discovery
and how to
 
1 - 4 of 4 Posts
Top