MR2 Owners Club Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have an ST215 Caldina engine in my ST165. The harness was done by Wiregap. The engine has stock compression Wiesco pistons, eagle rods and ARP headstuds. I have an overkill water to air intercooler and a 3 inch cat-less exhaust.

I'm having 2 issues and I think they could be related. First one is a super rich run under load. At 10 or so psi, I'll see my AEM wideband dips down to 9.8 to 1 AFRs sometimes... mostly I'll see 10.2 to 1 or so. The car has the Denso Supra Turbo pump and the stock sky blue injectors. I have an Aeromotive adjustable fuel pressure regulator set at about 41psi.

The other issue happens under load at 12 or so psi and up. I can feel a loss of power and a popping from the exhaust. It doesn't feel like a hard misfire, more like its firing out of time. Cam and crank sensors read fine (Using the big Autel diagnostic tool that has JODB). I'm wondering if the rich run has anything to do with it...sometimes the car pulls hard just fine when that rich. Also, it will hit a violent cut, like an over boost fuel cut without ever getting to the 17-18psi factory cut.

I happen to have almost 2 of everything. I have 2 caldina motors. I switched out knock sensor, coils, Map sensor and NGK BKR7E plugs gapped to .028.

Anyone else see problems like this?

Was also wondering about Prius Coils. I hear they are popular to use in high HP applications. Are they compatible with the stock ECU?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #2
Went by Napa and got a set of NGK BKR7E plugs and installed fresh from the box. I guess those rich numbers came from an incomplete burn. The car pulls hard under boost nicely. AFRs around 10.8 to 11 to 1.

I guess this is a lesson in checking the simple crap first.
 
1 - 2 of 2 Posts
Top