MR2 Owners Club Forum banner
1 - 8 of 8 Posts

·
They call me LUCKY!
Joined
·
4,923 Posts
did it get bent?
or have you compressed it all the way yet? might not be lubed up to slide through the gasket
 

·
Registered
Joined
·
2,149 Posts
Discussion Starter · #3 · (Edited)
I'm playing with it now as i type this...I can twist it, but can't push it in. Its not bent. You think I should try lubing it?

twosrus stuff rocks by the way even if this thing is broken.

EDIT: It works!!!!!!! jsut needed some lube, thanks!
 

·
Master of Twos R Us
Joined
·
21,741 Posts
MR2turboFAN said:
I'm playing with it now as i type this...I can twist it, but can't push it in. Its not bent. You think I should try lubing it?

twosrus stuff rocks by the way even if this thing is broken.

EDIT: It works!!!!!!! jsut needed some lube, thanks!
Actually, you aren't really supposed to be able to push it in by hand. A lot of people write me with 'this strut is defective!', but they just don't realize how much force #50 really is. If you could push it in easily by hand, it wouldn't hold up your engine lid. :)
 

·
They call me LUCKY!
Joined
·
4,923 Posts
thats the truth i was amaized at the strength of the one for the engine lid so small yet so strong
 

·
Master of Twos R Us
Joined
·
21,741 Posts
Eh, not stupid. I would have answered earlier, but I didn't realize what was going on. I thought you had it on the car and it was stuck halfway out.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top