MR2 Owners Club Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4,918 Posts
Discussion Starter #1
I've been running with an open downpipe for the last few weeks, and today I just got my 3" straight pipe exhaust in from Josh Boam (mister3). I bolted it up and everything was looking good. But, afterwards, I noticed my idle goes up and down occasionally (anywhere from 800-1100, without touching anything, just goes up and down every few seconds). I thought it could be a vacuum leak, but it's nothing major. Does it have anything to do with the sudden restriction of more exhaust flow? or what? Is it just a coincidence? If so, what else could it be?
 

·
Registered
Joined
·
178 Posts
Since the last thing you worked on was the exhaust, you should check there first. An exhaust leak before the o2s will cause this after it has reached closed loop. Check turbo to dp fasteners.
 

·
Registered
Joined
·
4,918 Posts
Discussion Starter #6
I never touched the downpipe though, I've had my KO DP on there since summer now. The vacuum on my gauge is at a normal in/hg, right around 20 I'd say. Though, every now and then, this goes just a teency bit up and back down... about 19-21 in/hg. The car still pulls hard as well. Ok, where are some "usual" places to check for leaks? I've already checked the BPV, it's on there nice n tight.
 

·
Registered
Joined
·
1,409 Posts
Air in the coolant perhaps? i dont know why that would change all of the sudden, but air in the coolant will give you a wandering idle.
 

·
Registered
Joined
·
4,918 Posts
Discussion Starter #8
I haven't changed the coolant since I bought the car (April 04) and I've been meaning to do this... It's so damn cold around here though!!! Well, that'll be one of my first things to do when it starts warming up.
 
1 - 8 of 8 Posts
Top