MR2 Owners Club Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
636 Posts
Discussion Starter #1
I just started my car and let it sit. And i left it for about 15 minuts. When i came back it was really idling low and the engine was shaking alot. Enough to rattle my hood. The i gave it a little gas and the car just stalled when it was going back to idle. What's up??
It's been doing this but getting worse and worse. And the car's been sitting also.
 

·
Registered
Joined
·
10,197 Posts
Could be misfiring. Check your plugs and wires. If it's an 85 or 86 also check the hose between the AFM and TB for big cracks.
 

·
Registered
Joined
·
636 Posts
Discussion Starter #5
it sounds fine when i put on some gas. It just stalled when i let go of the gas.
The car's been sitting for the winter and i start it up once a week. But this time it sounded rough. And whats an IAC?
 

·
Registered
Joined
·
2,905 Posts
check all your vacum lines. check your AFM to make sure it is on tight. Take the car for a drive and run some fresh gas through the engine and use a dry gas additive in the winter if you are storing it for long periods(over a month).
 

·
Registered
Joined
·
1,229 Posts
i'm having a bogging problem also...and i'm using old fuel...(about 3/4 months)....do you think this could be it?

To run fresh gas, you would syphon out all the old gas first??
 

·
Registered
Joined
·
2,714 Posts
pull your plugs, do you have water or oil in there?

also put some gas line antifreeze or drygas in there. this helps mix the gasoline with water so it can be combusted and burned out

i'd check the fuel filter in the car too and the car and rotor

~mikeym
 
1 - 8 of 8 Posts
Top