MR2 Owners Club Forum banner

1 - 15 of 14 Posts

·
Registered
Joined
·
1,101 Posts
Discussion Starter #1
Hey guys.... I have kind of weird problem. When I open the door the dome/maps lights don't come on. They work fine when I push the button for them. But do not work when I open the door. The switch on the door jam is working fine because when I open the door it triggers on the other lights (door panel lights'key ring light) all work fine when the door opens. And yes I flipped the dome light switch back and forth with no change. I never came across this problem before....Any thoughts???
 

·
Registered
Joined
·
1,101 Posts
Discussion Starter #3

·
Premium Member
Joined
·
11,822 Posts
I will guess that one of the contacts inside the dome light assembly has broken. That would happen all the time with the MK1 dome lights. The contacts were riveted, and eventually the rivets would crack. I would just drill the rivet out and replace with a #2 screw.
 

·
Registered
Joined
·
1,499 Posts
Does sound like a door wire could be the issue. To make these lights work with the doors the power has to make it to the Door Courtesy switch.
See attached image.

For the lights to work with the switches they earth at the switch which is why they work still.
SW20 1993 USDM Interior Lighting.JPG
 

·
Registered
Joined
·
95 Posts
I had the same problem, it’s usually a easy fix, take the light assembly out, on the back you will see brass rivets use a large centre punch and hammer, squish the rivet back down clean any corrosion off the contacts that usually fixes the problem.
 

·
Registered
Joined
·
42 Posts
I've got a similar condition with a twist. My passenger door won't do anything, my drivers door will kick the domelight on but it's super quick...like comes on and then fades back to off within seconds even though the door is still open.
 

·
Registered
Joined
·
70 Posts
I had the same issues, check the switch in the door jamb (should have a rubber boot over it). You can try shooting some electric grease into the plunger, but it probably needs cleaned out really good or replaced.
To get it out you will need to take the bolt out on the exterior side and get behind the interior panel behind your seats, it pushes through the hole into the interior of the car for removal. FYI, the rubber boot will not come off without undoing the bolt.
 

·
Registered
Joined
·
1,101 Posts
Discussion Starter #10
I had the same issues, check the switch in the door jamb (should have a rubber boot over it). You can try shooting some electric grease into the plunger, but it probably needs cleaned out really good or replaced.
To get it out you will need to take the bolt out on the exterior side and get behind the interior panel behind your seats, it pushes through the hole into the interior of the car for removal. FYI, the rubber boot will not come off without undoing the bolt.
Did you read my whole post??? That's working fine.
 

·
Registered
Joined
·
1,499 Posts
I've got a similar condition with a twist. My passenger door won't do anything, my drivers door will kick the domelight on but it's super quick...like comes on and then fades back to off within seconds even though the door is still open.
Mine does this sometimes. Doesn't fade though, that's far too fancy for an early 90s car. It's just my door switch and the rubber cover causing the issue though.
 

·
Registered
Joined
·
180 Posts
I had similar issue. It was the door switch. The spring and the copper contact worn out. I got a used one from a donor car issue solved.
 

·
Registered
Joined
·
4,250 Posts
My car came like this about 15 years ago and I just assumed it was the aftermarket alarm. Someone cut that wire so the door handle pull doesn't start the alarm or something.
Guess I will look into this more now I see this thread.
As well, my door lock ring has never lit up. I could look into that too, which I think is a burnt bulb and would switch to white LED's given the car is superwhite.
 
1 - 15 of 14 Posts
Top