MR2 Owners Club Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1,229 Posts
Discussion Starter #1
Ok well the guy i bought my 87 NA from also gave me 2 extra distributers and now i know why. I checked the codes and it looks like ill need to change mine is bad. anyway i was looking at the 2 extras, and theres a tiny difference. One has green connecters, while the other is dark grey. also note that my 87 has a bluetop, im not sure if it was swapped in. So which dizzy do I use? does it matter?

heres a pic


also, im getting a loud squealing sound mainly when i first go into gear. is this something to worry about? it goes away after a while, but its on and off. is this the timing belt? thnx for all the help, im an uber noob :angel:
 

·
Registered
Joined
·
7,127 Posts
Use which ever one has the same colors as the one installed now, the squealing sound is probably a loose alternator belt. If you look inside the distributors one probably has more teeth on the counter wheel than the other.
 

·
20v Super Two
Joined
·
5,026 Posts
I had to deal with the different distributors. There are two models both with different colors. Both will run the car, but one might throw a code. I really have no clue what it means, or what color goes with what, but I can tell you that my 89 had a grey body connector, and a grey dizzy connector. When it died, my mechanic got me a green dizzy and it threw a code. I found another one - still green, but for some reason it didn't throw a code.
 

·
Registered
Joined
·
1,229 Posts
Discussion Starter #5
wow...
confusing

anyways ill just see what i have in there and replace it with that i gues...now i gotto go steal someones timing light :)
 
1 - 5 of 5 Posts
Top