MR2 Owners Club Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
298 Posts
Discussion Starter #1
for some reason today when i got back in my car to go back to work, i turned it on, the cooling fan light, e-brake light- and battery light stayed on... (e-brake was not engaged either)... i thgouth that was odd, so i turned the car off, then turned it back on, problem solved....

well, after work i got gas, turned my car on at the gas station, same problem, only this time its not going away... also made my interior lights dimmer, and my windshield wipers go slow...

its almost like something grounded out somewhere or something cause the car starts and runs fine, just those 3 lights wont go out.... any ideas???
 

·
Registered
Joined
·
581 Posts
Sounds like the alternator. Hook up a voltmeter to the battery and have someone watch it while you start it. I'll bet it still reads battery voltage instead of raising to 13.6 or higher. If so, I reccomend replacement with a factory rebuilt. Bob
 

·
Premium Member
Joined
·
10,360 Posts
Sounds like you have alternator failure. Check the grounds, check the battery terminals and leads. After that take the alt to autozone and check it on the tester. After you get a new Alt. from said store, check it on the tester before you leave.
 

·
Registered
Joined
·
2,044 Posts
what they said. just to be sure, check your brake fluid as well.
 

·
Registered
Joined
·
581 Posts
Buy an alternator from Toyota, it lasts 150k to 200k. Aftermarket, you'll buy three. Just my experience, Bob ('85 since new)
 

·
Registered
Joined
·
83 Posts
i have a similar prob, but its just my e-brake, went away once when i went to my buddys but soon as i came home it went back on and wont go off
 

·
Registered
Joined
·
298 Posts
Discussion Starter #7
its really wierd, after the cars been sitting for a while, the problem goes away.... but then if i drive for a little while, then turn car off, and back on, problem is back... i guess ill go get my alternator checked out...
 
1 - 7 of 7 Posts
Top