MR2 Owners Club Forum banner

1 - 6 of 6 Posts
9

·
Guest
Joined
·
0 Posts
Discussion Starter #1 (Edited)
Hey All,

I'm new to the forum and am researching an ongoing problem on my Dad's MR2. I used the search first but didn't find anything exactly like what his is doing.

His is a '91 turbo with aftermarket intake & BOV & manual boost controller. When the engine has not reached full running temperature it bucks wildly if you do not shove your foot in it. If you just attempt to accelerate normally, it will actually decelerate if it doesn't buck. The only way to make it run right is to get it to full boost. The weird thing is that it doesn't always do this (occurs about 50% of the time.) He always lets it idle for several minutes before he drives it. Toyota dealership has no idea what the problem is... seemingly hadn't ever seen an MR2 Turbo before. Don't know of anyone else around OKC who actually knows how to work on MR2 Turbos. I've read that some MR2s do some similar things if the Mass Air is going bad. Others hint it might be ECU issues but he has a spare ECU and it didn't change anything. Then, I just read someone's car bucks due to their aftermarket BOV... but why would it quit bucking when the engine is at running temp?

Next problem is streaky performance above 5,000 RPM. Sometimes his car will do 60 MPH in 2nd gear, other times it runs out of guts at around 48 MPH/5,000 RPM. Is this related to the above problem?

Any ideas are greatly appreciated. I actually bought a '91 SC-V6 for him, so he'll be selling his soon. Would like to figure out what's wrong with it first though.

Thanks!

Ryan
 

·
Registered
Joined
·
5,392 Posts
I had similar problems with a previous MR2 I owned. A few months later, my AFM broke and after I got another one, that solved the problem. See if there is someone near you that you can swap out AFM's and see if that fixes it. It only takes 5-10 minutes to take off and put another one on. DONT unscrew the harness, but take the clip off around it and then just pull on the wiring harness and it will come out.
 

·
Registered
Joined
·
1,795 Posts
I'm thinking the BOV as well. Mine bucks a little too when its cold. I'm going to swap it out this weekend to see.
 

·
Registered
Joined
·
1,795 Posts
91SCv6 said:
Please keep me posted!
Sorry for the super late reply, finally go around it. Better late than never right? haha.

Well yah put the OEM valve back drives like a dream. The cold issues are gone. But I can't say for sure it will solve yours, but it's a start.
 
1 - 6 of 6 Posts
Top