MR2 Owners Club Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
143 Posts
Discussion Starter #1
I just finished doing my winter modifications, including ct20b, greddy intercooler, walbaro fuel pump, new downpipe and exhaust. Got everything together with no problems except one broken exhaust stud(93 manifold) and broken afm(replaced with used one), the car will fire up idle really low then bog and die even with pressing the gas down. tried to tighten all manifold bolts and charge pipes,...nothing has seemed to help.... if anyone could shed some light on any potential problems i may have over looked that would be awesome.
 

·
Registered
Joined
·
3,568 Posts
um... looks like what one of my buddys had with his 2. if it was starting up fine then idling low then dieing, then its probably the alternator, or if not that then probably when you where putting the afm in you might of losen up some other wires. but the problem your having now is what my buddy had in the past. just change that and your 2 will be fine!
 

·
Premium Member
Joined
·
11,937 Posts
Check the following:
* AFM
* Battery (just hook up some jumper cables to another car, if it runs okay, then it's not your battery/alternator)
* vacuum/boost leak somewhere in the intake pipes
* sparkplugs
 

·
Registered
Joined
·
143 Posts
Discussion Starter #6
this weekend my friend is coming over with his all trac that runs and were going to take out his afm and hook it up and see how it runs. so if it runs good i will be looking for a new afm so if anyone knows where i can find one let me know looking to spend about 100 bucks thanks
 
1 - 6 of 6 Posts
Top