MR2 Owners Club Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter #1
in the moddle of driving today my mr2 died , half a tank of gas, had oil and volt meter was fine , any ideas, cant get it started
 

·
Registered
Joined
·
6,985 Posts
If it just died and you are sure it is not the alternator...my next guess would be fuel pump, or fuel pump relay.
 

·
Registered
Joined
·
6,985 Posts
mr2oc91 said:
its fine now thanks
:confused:

What does that mean?

The problem won't just go away...if it is fuel pump related that is a common symptom (described above) and eventualy it will leave you stranded.

If you fixed the problem, let us know what it was so that others can perhaps learn from this thread. :thumbup
 

·
Registered
Joined
·
35 Posts
what was messed up was when mine died on me one day couldn't get it started changed the fuel pump checked the relay turned out to be the timing belt had snapped feel good at least it's probably a bad fuel pump because changing a snapped timing belt on an mr2 is a pain
 

·
Premium Member
Joined
·
5,587 Posts
MISTER2 said:
:confused:

What does that mean?

The problem won't just go away...if it is fuel pump related that is a common symptom (described above) and eventualy it will leave you stranded.

If you fixed the problem, let us know what it was so that others can perhaps learn from this thread. :thumbup

I agree -it's not fair for you to ask for help but then not add to the common data base. By telling us what it was, anyone doing a thread search later will be able to make use of this thread.
 

·
Registered
Joined
·
42 Posts
Discussion Starter #9
sorry about that it started up after a while im not sure what it was im gonna take it to my mechanic to have it checked out when i find out ill let you know
 

·
Registered
Joined
·
42 Posts
Discussion Starter #10
i dont know much about that my neighbor said it might have something to do with the weather that day because he had the same problem. it was monssooning out alot of flooding
 

·
Premium Member
Joined
·
5,587 Posts
Or could be water in a connection in the ignition circuit. Check your connections as there may be a loose connection or a shield out of place, and there could be a short somewhere (i.e., a bare wire grounding out).
 

·
Registered
Joined
·
35 Posts
is also a possibility that your air filter got to wet and it couldn't get any air in the intake causing the engine to choke for lack of air again just a possibility
 
1 - 13 of 13 Posts
Top