MR2 Owners Club Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter #1
So i have some Boston Acousic Pro 6.5's sittin here. i wanna put them in my 93 in the doors but i know that they require decent power to them to sound like anything. Has anyone installed them in a MKII and how do they sound. I'd really like to know if you ran them off of the stock amp or an aftermarket one. I'd rather not have to wire up and amp if i dont have to.
 

·
Registered
Joined
·
3,568 Posts
i have them in my 2... and they sound great!! but yeah i just wired it up to the stock amp... sounds fine to me but if your bass hungry you might want to go with another amp...good luck!
 

·
Registered
Joined
·
2,279 Posts
I do not recommend running boston pros off the stock amp or the headunit. They are a pretty high class speaker and require alot of power to make it worthwhile. Reading on caraudio.com it sounds like you need to be pumping 300w into each one to get the most out of it. Even with my boston SL60s (one step below the pro60's) I noticed a HUGE difference when I went from 50x2 to 150x2. Yes I tripled the power and you can definitly tell.

If you dont plan on getting an aftermarket amp I would recommend selling them and picking up some cheaper less power hungry speakers. Plus the difference between 350 dollar speakers (as the pro60's are) and 100 dollar speakers running at 30w (or whatever the stock amp is, I have no idea) is going to be marginal at best.
 

·
Registered
Joined
·
3,568 Posts
will i have them running on the stock amp and they sound fine... but then again i dont bump like most poeple... hahhaha but on the other hand i think and like the way i set them up cause i think that the clearity level is way better than most other brands... but hey junkie, my best advise is for you to just do wat you would like to cause its your car and it'll be the way you want it to be so the real choice is up to you. good luck with it PM me if you have any questions...id be more than glad to answer them... just sorry about that first one... ahhahah i was like.... erm... im lost... hahahah but yeah good luck!
 

·
Registered
Joined
·
484 Posts
my piece of advice, put them in, listen, if you like good, if not amp or change out. i personally amp everything, best sound and can crank it when i want. just remember your sound will only be as good as the weakest part of the system (could be amp, spkrs, radio, wires.....)
 

·
Registered
Joined
·
2,553 Posts
I had BA 6.5 Pro's in my M Roadster. They were powered by an Alpine 100Wx2 amp. I wasn't very happy with the results and thought they needed a lot more power.
Check here for my write up.
http://www.scottbarton.net/BMW/Stereo

-Scott
 

·
Registered
Joined
·
2,279 Posts
Yeah I was even thinking about upgrading to pro60's but I've heard even at 150x2 it may not be enough.
 
1 - 7 of 7 Posts
Top