MR2 Owners Club Forum banner
1 - 18 of 18 Posts

·
Premium Member
Joined
·
2,254 Posts
Discussion Starter · #1 ·
According to the BGB, the Primary somethin-or-another is supposed to be between .4-.5 ohms. The Secondary somethin-or-another is supposed to be between 10-14 k ohms.

My primary read between .8-1.2
My secondary didn't even get a reading

Is my ignition coil bad or is my ohm meter bad? If it's the ignition coil then I think I found my spark problem :) Let me know please!
 

·
Registered
Joined
·
5,287 Posts
Do you have a scale for reading up to 20K ohms? If so try reading something else that is approximately the same. Get a 15K resistor and measure it. That should tell you whether or not your meter is the problem.
 

·
Premium Member
Joined
·
2,254 Posts
Discussion Starter · #4 ·
No its not running at all and I'm trying to figure out the problem.

I measured the distributor pickup coil and the reading on those came out ok so I think it is my ignition coil. Would you agree that it isn't my meter?
 

·
Registered
Joined
·
5,287 Posts
SwpdMR2 said:
The BGB didn't say to check the coil wire.
I am simply offering you a suggestion to try something else that may be in the neighborhood of resistance as the secondary of the coil. It is highly likely that your ohmmeter has a weak battery. The higher the resistance, the more likely the battery is to be the problem.
 

·
Premium Member
Joined
·
2,254 Posts
Discussion Starter · #13 ·
I hear ya, I thought the meter was bad too until I tested the pickup coil on the distributor and everything read fine there. I think I'm going to grab a new ignition coil. It's a rusty mess, maybe it being old has something to do with it.
 

·
Premium Member
Joined
·
2,254 Posts
Discussion Starter · #16 ·
I replied...and I wanted to say thank you to byron and chris for your quick and responsive help, and thanks to you ddtprm for supplying me with a good one, hopefully this does the trick.
 

·
Registered
Joined
·
2,270 Posts
SwpdMR2 said:
I replied...and I wanted to say thank you to byron and chris for your quick and responsive help, and thanks to you ddtprm for supplying me with a good one, hopefully this does the trick.
no prob man. glad i could help.
 
1 - 18 of 18 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top