MR2 Owners Club Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
215 Posts
Discussion Starter #1
i'm having some problems with my car and i'm wondering if the AFM is to blame.

problems are:

no radio/intermittent failure of center console (dash clock and lighter as well as radio).

stumbles under load. half throttle or more it will nose dive and jerk around badly.

bad gas mileage. talking 17-22MPG.

runs rich and while the engine is cold/first started it blows alot of smoke that smells like gas.

as of late the car hasn't wanted to start. it will crank and crank but it takes it forever to actually get going. most of the time when it does kick over it will sound like it's running on like 2 cylinders until it gets going a bit.

things i've tried.

i've replaced the plugs and wires already, in the process of the cap and rotor. done the fuel filter. checked for boost leaks and repaired them. replaced the battery and checked the alternator's voltage. alt reads 13.9 at idle. turn the head lights on and it dives to 13.4 and goes back up to 13.6. click the high beams on, 13.5.

my theories.
something is funny electrically. wiring problem, sensor problem... something.
timing belt jumped a tooth. this isn't really a large possibility because i can't really put the thing under load so it's not like i'm racing and revving the engine alot. i do have a squeeky pully though. !

would really appreciate any help i can get. i have several other opinions ranging from fuel pump to AFM to bad ground wire somewhere
 

·
Registered
Joined
·
201 Posts
i had some of those symptons when my afm went bad, try to find a used one to swap and you'll know right away
 

·
Registered
Joined
·
811 Posts
emericanchaos said:
what would cause fuel cut?
-Fuel Cut hits at 12 psi for 91-some of 93, and 93+ is at 16 psi. It would definently hit fuel cut if you raised the boost and didn't have a FCD installed.
 
1 - 8 of 8 Posts
Top