MR2 Owners Club Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
125 Posts
Discussion Starter #1
Well my 91T is running in safe mode. 2 codes I cant seem to clear; Knock sensor (which I replaced) and excessive boost. I pretty much did all I could do. I reseted the ecu and have no luck. once i put my foot on the gas the CEL comes right on or i have some days when it will take a few mins for the safe mode to get activated. If there is anyone in san diego thats willing to help me sort this problem out I would greatly appreciate it to the deepest of my heart. Thanks..
 

·
Registered
Joined
·
125 Posts
Discussion Starter #3
Thanks! but i pulled the fuse already i guess it wouldnt hurt to pull the battery out at this point.
 

·
Registered
Joined
·
125 Posts
Discussion Starter #5
Hajimoto MR2 said:
or replace the wire to your knock senser.
Where does the knock sensor end? Could I add my own wire and just splice into my the exsisting connectors or is it a trip to the dealer? Thanks
 

·
Registered
Joined
·
4,109 Posts
The wire ends at the CPU plug and starts at the knock plug. Replace the entire wire as close as you can to the connecters at the cpu and the plug. You can buy the wire at any decent electrical place. Willeys in Nasty City should have it. Its a type of co-axle wire. ITs cheep, like three bucks to do the whole thing. I was always told that the k senser rarely goes bad. Its the wire that does.
 

·
Registered
Joined
·
125 Posts
Discussion Starter #7
Hajimoto MR2 said:
The wire ends at the CPU plug and starts at the knock plug. Replace the entire wire as close as you can to the connecters at the cpu and the plug. You can buy the wire at any decent electrical place. Willeys in Nasty City should have it. Its a type of co-axle wire. ITs cheep, like three bucks to do the whole thing. I was always told that the k senser rarely goes bad. Its the wire that does.
pm sent! Thanks man
 
1 - 7 of 7 Posts
Top