MR2 Owners Club Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1 (Edited)
I got my 92 NA with a swapped 1mzfe. It cranks but there is no spark. I checked the coils and resistance is good. I have 12v from the pigtail plug to the block and the only codes I’m throwing are for shift solenoids. I have done everything I can think of minus checking the crank position sensor, that’s next. I have even tore apart the security system that was installed by a previous owner and disabled it, but that kills the starter not the spark. Every now and then I get a small hiccup where it fires once with starting fluid. But even with fluid it just cranks away.
 

·
Registered
Joined
·
213 Posts
Are you certain that you don't have an immobilized ecu. If not, you may need a new ecu. First, check all of your grounds.
 

·
Premium Member
Joined
·
3,513 Posts
I don't have much experience with the 1MZ, but the 2GR cuts spark and fuel for the immobilizer but that "every now and then" hickup might be the same thing as the 2GR. The first time you start an immobilized 2GR ECU it'll fire for 3-5 revolutions then die and not spark/fuel until the battery is disconnected and reconnected.

I'd see if you can get that kind of behavior and that'll likely confirm the immobilizer presence. But unless you specifically bought it with immobilizer disabled/removed from a reliable source there's a really good chance it has an immobilizer on there.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #6
I know it has the immobilizer in it. What do I do with it? It also looks like one of the previous owners installed a camry security system in the car.
 

·
Registered
Joined
·
1,283 Posts
There's a guy that can disable your 1MZ-FE ECU immobilizer. You will have to send him the ECU. I think his usernmame is Apokryphos or something like that. On facebook he is in the MR2 groups and his name is Joseph Mensh.
 
1 - 7 of 7 Posts
Top