MR2 Owners Club Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Just bought a 91 NA. Brought it home and put a new battery in it. It cranks but won’t start. While the key is turned to the position before cranking, there is a whirring sound coming from the front of the vehicle. Sounds almost like a fuel pump priming or a vacuum but it is louder and continues until key is removed. Any ideas what this could be?

thanks! New here
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
That’s what I thought at first. But the sounds coming from up towards the dash/battery area. Also I can’t get any codes out of it. Did the paper clip. Nothing :/
 

·
Premium Member
Joined
·
11,949 Posts
Power steering, radiator fan and cabin fan are the likely candidates. Don't know if your car has power steering, but you will not get fuel pump until you crank unless the crash interlock has been bypassed. If the crash interlock has been bypassed, it would be a good thing to restore. It is there to save you from burning to death if you can't turn off the ignition.
 

·
Registered
Joined
·
2,068 Posts
Have a look under the hood beside the battery when you do this. Under the spare wheel and plastic cover if it's still there. Under a big rubber cover is the PS pump. It is meant to not run with the engine off if set up as per the original car and not run until the engine is running. However it is possible for it to run for at least 30 seconds before it shuts off when you turn the key to ON and don't touch the steering wheel.
 

·
Registered
Joined
·
1,565 Posts
Probably the power steering. My car's power steering starts up before cranking and it works up to a reeee sound

Normal, never had an issue with it
 

·
Registered
Joined
·
1,565 Posts
Does yours have a GEN4 swap?
No, IIRC it's been like this when I first transitioned over to gen3 EFI with an ST205 ECU. To my recollection I leave PSCT disconnected since the All Trac ECU can't run it, so it runs at all times.

This is the noise, is this what it is?

There's the whoosh of my IC fan coming on with ignition, but the other mechanical sound is the EHPS.
 

·
Registered
Joined
·
2,068 Posts
Ah yes. The ST205 ECU has no PSCT output so will make the pump run like that. Not a normal MR2 ECU thing to happen. However hooking up the PSCT wire to either the oil pressure light wire or the FC wire on the ECU will make it work as per the MR2 ECU.
 

·
Registered
Joined
·
1,565 Posts
Ah yes. The ST205 ECU has no PSCT output so will make the pump run like that. Not a normal MR2 ECU thing to happen. However hooking up the PSCT wire to either the oil pressure light wire or the FC wire on the ECU will make it work as per the MR2 ECU.
I guess I'll double check, but I think I did that in the past and it put the ECU in limp mode or gave other issues for me?
 

·
Registered
Joined
·
2,068 Posts
I guess I'll double check, but I think I did that in the past and it put the ECU in limp mode or gave other issues for me?
I have not actually tried it myself. Still building a harness and waiting for the engine it is going on to be put back together.
 

·
Registered
Joined
·
2,068 Posts
Mine makes the same noise. I assumed it was the fuel pump priming. I'll get a video for reference.
With a factory ECU the fuel pump will not run unless cranking or running. If the car has been messed with or has some form of aftermarket ECU then it could run with the engine off.
 
1 - 15 of 15 Posts
Top