MR2 Owners Club Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
142 Posts
Discussion Starter #1
I have a 2nd gen turbo motor. I have been getting 8-12 mpg for awhile and wondering what the problem is. I have a list of considerations, but can't narrow down the problem.

1)a/r ratio meter is almost always rich
2)car starts bad in the morning
3)I get better(not great) gas milage when I have driven it for awhile.

so this is the weird part-
1)The o2 sensor tip is white. Which should mean the the car is running lean.
2)The spark plugs were barely white, but still not normal.

any help would be appreciated.

jeff
 

·
Registered
Joined
·
380 Posts
jeff they say a/f meters dont give any decent reading unless you have a wideband o2 sensor connected to Downpipe. so dont go off that reading, i get about 15 mpg which is bad also, but not nearly as bad as you're getting
 

·
Registered
Joined
·
142 Posts
Discussion Starter #3
yes I have heard this also. I just don't get it because one of my friends virtually has the same setup, but gets around 25-27 mpg.
 

·
Registered
Joined
·
142 Posts
Discussion Starter #5
I seriously baby it. I don't drive hard at all. 8mpg doesn't allow my to drive hard and make it home with gas left.
 

·
Registered
Joined
·
4,344 Posts
The stock narrowband should be switching, even at warm idle. You should see it jumping around, not pegged rich.

This could be one or more leaky injector. Put a gauge on it and measure the fuel pressure. With the pump on, engine off it should be around 33-38. Then, shut off the pump. The pressure should remain high for minutes.

If it fails the first test, then suspect your regulator. If it fails the second, then suspect a leaky injector and send your injectors (plus the cold-start) to www.witchhunter.com.
 

·
Registered
Joined
·
142 Posts
Discussion Starter #7
its not rich at idle. its lean at idle. Atleast thats what the gauge says. I guess I will start taking out the injectors unless anyone else has any ideas.
 
1 - 9 of 9 Posts
Top