MR2 Owners Club Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #1
Hi everybody,

I have a 3SGTE 4gen swap. Car doesn't throw CEL errors and runs fine slowly (I can't test under load or high boost conditions yet).

But, when I go for 1.500 - 2.500 rpm, you can notice there is a strange sound (I don't know if it is normal). I have attached a short video where you can see and hear this sound.

It's like wind inside the engine, like a whistle. Very rare comparing other engines I have seen.

Any idea is welcome :)
Thank you in advance!Tapatalk Cloud - Downlaoad File InShot_20200601_002930031.mp4

Enviado desde mi G3112 mediante Tapatalk
 

·
Registered
Joined
·
22 Posts
Discussion Starter #6
Ok still there. Does it change when you push in the clutch? Or it could be a heat shield rattling. I know my 3SGE makes some horrid resonance at 1,750rpm which I am sure if I had any loose parts would rattle.
It makes the same sound when I push the clutch or not. I think you are right, maybe any light resonance makes a horrible noise. Or maybe, it could be any pulley or tensioner in the timing belt?

Enviado desde mi G3112 mediante Tapatalk
 

·
Registered
Joined
·
2,068 Posts
It's always hard to tell from a video but easier than having no video at all. Doing the pipe test for sound is a good idea as like you probably know sounds can seem like they are coming from somewhere else when they are not. Unfortunately I'm out of ideas.
 

·
Registered
Joined
·
364 Posts
Is this gen 4 installed in a Celica?
Have you taken off the timing belt cover and run the engine? It sounds like the plastic cover is rubbing against the pulley, the belt or the cam gear. It’s just my two cents.
 
1 - 8 of 8 Posts
Top