MR2 Owners Club Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 · (Edited)
3S-GE WIRING DIAGRAM NEEDED

3S-GE WIRING DIAGRAM NEEDED Hope someone can help. Please....
I have a british 1991 mr2 2.0 with a 3s-fe engine and have swopped the engine for a 3s-ge with autobox, import 1991 and the only real trouble i come across is that i am a plug missing from the ecu.
the new engine came with the enging wiring loom and ecu and i think there must be another loom on the car which was scapped.
what i need is wiring diagram of both engines so i can compare and rectify the differences.
The autobox was replaced with manual transmission no problem and the engine bolts in no problem.
The vehicle does starts on cranking and then stops. (suspect fuel pump -no feed).

Thanks Jeff
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #2 ·
A bit closer

I ended up going to breakers yard and cutting as much of the missing loom as possible. Found some ecu pin data on autodata and tried to follow the pin sequence.
After connecting all the wires i thought i required it now starts and runs for about 10 seconds and dies.
I read in a book that the pump relay as 12-14volts when cranking and 0volts on idle, but when i checked the relay with a test lamp I do not get a 12v feed to the green wire /white stripe and one grey band. can anyone tell me if this is correct on the fuel pump relay.
Also i have noticed i am missing a wire from terminal A1 which should be a 12v feed and terminal A13 is also missing which should run to another relay.
Can any one help with terminal or wire colours......Anything.

Thanks Jeff
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top