MR2 Owners Club Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
2,176 Posts
I dare you to leave that outside in the winter around here. :)

...but then again, I know that's not going toward that purpose.

I guess all you can do is try it.
 

·
Administrator
Joined
·
42,297 Posts
Discussion Starter #4

·
Administrator
Joined
·
42,297 Posts
Discussion Starter #7
Ya, I am used to carrying jumper cables.
I don't have a stereo installed.
I think Deno is using the same battery. I remember a thread a few years (5 years?) back where we were discussing this stuff.
 

·
Registered
Joined
·
4,293 Posts
Don't you still need to have the battery vented for SCCA regulations even if it's a dry-cell? I guess it's worth checking before you mount it

Or I guess that's only inside the cabin right? Sealed & vented box?
 

·
Registered
Joined
·
602 Posts
i've talked to a few people that have them, and they seem to have no issues with them. only downside is that some of the tiny batteries dont have much reserve capacity.
 

·
Administrator
Joined
·
42,297 Posts
Discussion Starter #11
I can hook the car up to a battery maintainer when I park it. Or just use my disconnect switch I have on the Toystar. I'll probably just do that. I will only be driving this car to MR2 events.
 

·
No! My car is not cute!
Joined
·
1,776 Posts
I have had the 680 for like 3-4 years. The Battery has only just gotten to the point where if I leave the car sitting for a more than a week it'll be dead. when I first got the battery I could leave it for at least a couple or 3 weeks and it would still start. I think it's a great little battery and am planning on buying another in a month or so.
 

·
Premium Member
Joined
·
10,360 Posts
I have the PC680MJ. When my alt died, I had to drive with the battery only for 45 miles or so. With parking lights and wipers on. The battery worked like a champ.
 

·
Registered
Joined
·
27,751 Posts
I have the 680 in Hyde. I've only ever had issues when it gets cold outside.
Other than that, it starts up with no problems.

 

·
Registered
Joined
·
2,044 Posts
ive put a 320cca tractor battery in my car, starts just fine:) course that is kinda off topic huh:)
 

·
Registered
Joined
·
213 Posts
I have the 545MJ in the frunk. No problems with starting, even if it sits for two to three weeks. Its parked in the garage in CA, though, so winter starting is not a problem ;-)

I did leave the key in the "ACC" position overnight once, and it was dead the next morning. Took a slow (2 amp) charge for a couple of hours and hasn't given me a problem since.
 
1 - 18 of 18 Posts
Top