MR2 Owners Club Forum banner

spark

  1. MKII, 90-99 NA & Turbo
    My mr2 turbo cut out the other day while driving, tried to start it again and it just cranked and cranked, no stutters or anything, got it towed home, checked fuses etc and nothing there, the king lead to the distributor has voltage but it’s at 6v when cranking and I’m guessing this is too low...
  2. 3SGTE Turbo
    I'm new here and I need help with this ongoing problem. I own a JDM 1992 MR2. Body has over 200,000 km but I replaced the engine in 2012 with about 50,000km. Car had been running fine for years until a few weeks ago when I drove it to an appointment and when I wanted to leave I had trouble...
  3. 3SGTE Turbo
    I have a N/A body and have installed a 3rd Gen 3SGTE. Pins on ECU have been repinned accordingly as I've used many threads on here to get correct color coded diagrams for N/A to ST205 wiring for body harness. 1) Does the N/A body harness have a connector/wiring for the Gen 3 fuel pump relay...
  4. Normally Aspirated
    Greetings, everyone! Yesterday i was driving down the highway at about 80 MPH and suddenly i noticed that when i pressed down the gas pedal, the vehicle wouldn't respond and go faster. I immediately took the next exit and popped up the engine bay lid to see what was going on. My first thought...
  5. MKI, 84-89 NA & SC
    Hi, Just purchased an aw11 with a 20v and EMS stinger 4424. The wiring isn't the best and at the moment there is no spark. There is signal to the coil however no spark at the plugs. As soon as the ignition is on, the tacho shows 4000rpm. I believe the tacho gets its signal from the coil so...
Top