MR2 Owners Club Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-7 of 7 Results
  1. MKI, 84-89 NA & SC
    I bought an 86 aw11 and have been trying to get it running on its own feet. When i first got it the fule pump was out so we couldnt get it going by itself, but she purs off just starting fluid. So we droped the tank and got the fule pump in it, and now it chops over till about 1500 rps and then...
  2. 3SGTE Turbo
    Good evening any info will help greatly Cant always get into 3rd or 5th gear almost feels like nothing is their . Sometimes will grind but most of the time I goto shift and feels like nothing and won’t go in . Any idea what it might be ?
  3. 3SGTE Turbo
    So this problem just sprang out of nowhere about a week after buying this car. Its stock, has a new trans, and about 60k on the motor. I've replaced the coolant temp sensor already as recommended by another user, I thought that fixed it, and then returned to its usual idle for 5 minutes then...
  4. 3SGTE Turbo
    Hey guys a bit of troubleshooting needed! I got a SW20 1992 with 3sgte, mostly stock other then air filter, exhaust, downpipe and running on 11psi boost which I just tweaked up from 7psi couple of weeks ago. The other day went out for drive, revved high and boost was good however when I stopped...
  5. MKI, 84-89 NA & SC
    I let my brother test drive it one time and he blew out third gear. So I did the right thing, and pulled the entire engine and replaced the transmission with a C52. Upon reassembly, I cannot get the car to start. Initially the grounding was bad due to a cut ground wire. Checked spark, timing...
  6. General MK2 FAQ (Newbie Center)
    I've been looking at this MR2 that was listed for sale for the past hour now, and I cant find anything about the rear badge. the badge on the rear says "2.0 T" where the normal "turbo" badge would be. I was wondering whats the difference between the two. I cant find anything else about it any...
  7. MKII, 90-99 NA & Turbo
    Hi guys, this is my first post here, I'm looking for some help... I found a nice set of wheels I love but theyre 17x7.5 +40, I know the flush fit is around 29 & 16 staggered. I'm wondering if anyone has tried this size or know if it works, I'm thinking I might need a 1" spacer on the rear, &...
1-7 of 7 Results
Top