Replace AC amp - MR2 Owners Club Message Board
 4Likes
  • 1 Post By rmeller
  • 1 Post By merryfrankster
  • 1 Post By merryfrankster
  • 1 Post By tdaustinmr2
 
LinkBack Thread Tools
post #1 of 16 (permalink) Old July 4th, 2019, 13:53 Thread Starter
Registered User
 
Join Date: Jul 2012
Age: 41
Posts: 18
OldTrader Rating: (0)
Replace AC amp

Hey guys I bought part number 88650-17130 for my 93 turbo, AC amp.
Was told my AC wasn't working likely because this part needed to be replaced
took out glove box was told it would be near there..I don't see it.
Could someone walk me through where this part is..and how I can replace it. I would very much appreciate the guidance.

Thanks!
Attached Images
File Type: jpg 20190704_125855.jpg (71.1 KB, 29 views)
VoltageMr2 is offline  
Sponsored Links
Advertisement
 
post #2 of 16 (permalink) Old July 6th, 2019, 10:22
Lifetime Gold
 
Join Date: Jan 2007
Location: Ithaca, NY
Age: 67
Posts: 11,677
OldTrader Rating: (3)
Probably on the firewall underneath the dash.
VoltageMr2 likes this.
rmeller is offline  
post #3 of 16 (permalink) Old July 6th, 2019, 12:05 Thread Starter
Registered User
 
Join Date: Jul 2012
Age: 41
Posts: 18
OldTrader Rating: (0)
Do I have to remove the AC evaporator to remove it?
Any instruction on how to do this correctly?
VoltageMr2 is offline  
Sponsored Links
Advertisement
 
post #4 of 16 (permalink) Old July 6th, 2019, 13:02
Registered User
 
Join Date: Nov 2008
Age: 67
Posts: 177
OldTrader Rating: (4)
IIRC, look back up behind the evaporator housing between the housing and the footwell/firewall. In other words, on the side exactly opposite of what is seen in the photo. You need to stick your head down there or use a mirror to see it. I cannot remember if some of the evaporator housing bolts/clips needed to be removed to provide enough wiggle room for the housing to get the amp out.
tdaustinmr2 is offline  
post #5 of 16 (permalink) Old July 6th, 2019, 13:19
Registered User
 
Join Date: Feb 2016
Location: Maui, HI
Posts: 1,198
OldTrader Rating: (0)
No need to remove or move the evaporator housing. Get the carpet out of the way. Use some tiny tools. I re-installed mine with zip-ties.
merryfrankster is offline  
post #6 of 16 (permalink) Old July 6th, 2019, 13:41 Thread Starter
Registered User
 
Join Date: Jul 2012
Age: 41
Posts: 18
OldTrader Rating: (0)
Quote:
Originally Posted by merryfrankster View Post
No need to remove or move the evaporator housing. Get the carpet out of the way. Use some tiny tools. I re-installed mine with zip-ties.

thats very helpful I feel it behind the evaporator housing
I can't see how it screws in though, how many screws are holding it in place?
I don't mind zip typing back in place but need to remove somehow..

really appreciate the help guys hoping this fixes my problem, its hot in Texas!
VoltageMr2 is offline  
post #7 of 16 (permalink) Old July 6th, 2019, 14:21 Thread Starter
Registered User
 
Join Date: Jul 2012
Age: 41
Posts: 18
OldTrader Rating: (0)
Alright. Got it out. Two small screws. Here is the side by side of the new and the old.
I just put the bracket on the new one and screwed it back in..once I knew where located got out in 2 mins.
Thanks everyone.

Unfortunately spent a 130 bucks on a new amplifier from toyota..and AC still doesn't turn on. The green light not even turning on now..it started off as making a loud clicking sound under the glove box, than it turned off completely. Fan's blow, but no AC..back to the drawing board.

If anyone has advice on what else I should look at please let me know..thanks.
VoltageMr2 is offline  
post #8 of 16 (permalink) Old July 6th, 2019, 14:22 Thread Starter
Registered User
 
Join Date: Jul 2012
Age: 41
Posts: 18
OldTrader Rating: (0)
See pic
Attached Images
File Type: jpg 20190706_135901.jpg (139.8 KB, 22 views)
VoltageMr2 is offline  
post #9 of 16 (permalink) Old July 6th, 2019, 14:39
Registered User
 
Join Date: Feb 2016
Location: Maui, HI
Posts: 1,198
OldTrader Rating: (0)
That loud clickin sound was your ac clutch relay triggering. Next thing happened probably is your compressor seized. IDK.

PS. Let me try to be more helpful. With the car shut off, unplug the compressor from the harness. Then take a 12v power source and power the a/c clutch directly through its connector. The clutch should click audibly or you might even see the wheel move. This tells you whether it is working or not. If not working then remove and replace the compressor. If working continue.

Next grab yourself an ac manifold gauge and hook it up to the hi side and lo side fittings in the frunk. Turn the car on and turn the ac on then read the pressures. This will tell you if you have any refrigerant in the system. If not enough refrigerant, recharge.

If you have refrigerant and your compressor is ok then you proceed to troubleshooting hell. Can't help you with this. Consult the BGB. I would personally start with jumpering the ac clutch relay to force the system on. When you do this you can also force the ac fans on by disconnecting the radiator temp sensor from the harness. You will have makeshift ac. Better than no ac at all.

Last edited by merryfrankster; July 6th, 2019 at 14:51.
merryfrankster is offline  
post #10 of 16 (permalink) Old July 6th, 2019, 16:10 Thread Starter
Registered User
 
Join Date: Jul 2012
Age: 41
Posts: 18
OldTrader Rating: (0)
so i found the AC fuse had blown
replaced this
turn car on, green AC light comes on! Nice.
Stays on for a min, some sort of loud sound, no idea..
than turns off and fuse blows..
awesome
VoltageMr2 is offline  
post #11 of 16 (permalink) Old July 6th, 2019, 16:30
Registered User
 
Join Date: Feb 2016
Location: Maui, HI
Posts: 1,198
OldTrader Rating: (0)
I suspect that your compressor is damaged.
Abesdub likes this.

Last edited by merryfrankster; July 6th, 2019 at 16:32.
merryfrankster is offline  
post #12 of 16 (permalink) Old July 6th, 2019, 16:45
Registered User
 
Join Date: Feb 2016
Location: Maui, HI
Posts: 1,198
OldTrader Rating: (0)
this is a relevant excerpt of the BGB. AC wiring diagrams.
Attached Files
File Type: pdf AC-8 - AC-11 - Description descript.pdf (144.2 KB, 6 views)
Abesdub likes this.
merryfrankster is offline  
post #13 of 16 (permalink) Old July 7th, 2019, 07:30
Registered User
 
Join Date: Nov 2008
Age: 67
Posts: 177
OldTrader Rating: (4)
+1 on the recommendations from merryfrankster
My supplementary comments are :
1) as stated by merryfrankster, find the AC connector. It is a single wire connector above the compressor hanging near the intercooler fan. I remember it as a grey connector.
2a) disconnect this AC connector
2b) Make a jumper to a 12V source. I have used a wire between the main power terminal inside the relay/fuse box in the engine compartment. Be VERY careful with this technique, otherwise lots of sparks and possible other damage.
2c) Turn the engine on and turn on the AC controls.
2d) check if the compressor is kicking on and off by inserting and removing the jumper into the AC connector (again, be careful with live electricity)
3) If compressor is turning on : leave it on (but only for a very short time), then quickly check the AC line viewport in the front trunk. You should see fluid flow. If no flow or minimal flow, immediately disable the AC compressor jumper (i.e. turn it off) because you are probably out of freon and you do not want to damage the compressor.

Proceed with normal AC troubleshooting steps using the results of the above tests. However, I agree with the merryfrankster implication that a blown AC fuse suggests that the compressor is drawing excessive current, i.e. is dead or dying.
Abesdub likes this.
tdaustinmr2 is offline  
post #14 of 16 (permalink) Old July 7th, 2019, 18:40
Registered User
 
Join Date: Jul 2016
Posts: 843
OldTrader Rating: (0)
Agree with above on performing diagnostics on ac compressor. The compressor clutch seems to be causing a short when you turn on AC button. Try to squeeze your hand in to see if you can feel the compressor clutch turning easily check for seized or binding feeling.
Abesdub is offline  
post #15 of 16 (permalink) Old July 9th, 2019, 20:17
Registered User
 
Join Date: May 2019
Location: Northern Va
Posts: 7
OldTrader Rating: (0)
I am having a similar issue on my '93 NA, but I have confirmed my compressor works fine but am getting the system to work intermittently (if anyone wants to chime in on my issue, please reply in that thread).

I don't agree that a siezed compressor is blowing the fuse. If I'm not mistaken the only electrical power to the compressor is to the magnetic clutch, which should not draw excessive current even if the compressor is seized. Unless, like Abesdub mentioned, the clutch itself is drawing more current than it ought to for some reason, or is shorted.

When I get a chance, I'll try to get a current reading from my AC clutch so you have something to compare to.
adcox117 is offline  
post #16 of 16 (permalink) Old July 21st, 2019, 20:39
Registered User
 
Join Date: May 2019
Location: Northern Va
Posts: 7
OldTrader Rating: (0)
Welp, I've been busy troubleshooting my own AC problem (and working on the truck), but managed to re-write the BGB troubleshooter so you should be able to properly troubleshoot the amp. It's attached in my post titled "93 NA A/C Problem" (I can't post links yet).
adcox117 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the MR2 Owners Club Message Board forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: (0 members)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome