1991 turbo hardtop - MR2 Owners Club Message Board
Reply
 
LinkBack Thread Tools
post #1 of 23 (permalink) Old November 14th, 2015, 23:57 Thread Starter
Registered User
 
Join Date: Oct 2015
Location: Redondo Beach
Posts: 29
OldTrader Rating: (0)
Garage
1991 turbo hardtop

I was in the right place at the right time and got this car for almost free. A buddy was leaving the country and offered to give the car to me as long as I pay for a tow to my house and make it a project. The tow was $140 and it needs a battery, but you can't beat that price. The history I got is promising- the car is not running and hasn't been driven for 18 months. My friend bought it from another guy that made a couple questionable mods; a body kit and a terrible paint job. But the good news is what my friend put into the driveline. This list came from him:

91 MR2 Turbo (Manufactured 01/90) SW21/3S-GTE Hardtop

JE Pistons
ARP bolts (Head studs, Mains & ARP Pro custom rod bolts)
Bored 20 over
O-Ringed, shaved & detailed block
Balanced, chamfered, polished crank, rods… (Automotive Balancing)
Mild porting/polish & deck
RD valve springs, 8500 RPM
3 angle valve job (head done at West Coast)
HKS triple layer metal head gasket
HKS cam timing gears
Supra fuel pump
Supra 550cc injectors
HKS VPC vein pressure converter
HKS mega-flow intake
G-Force ECU daughter board, tuned by Tadashi @ TechnoSquare (12# boost)
Turbo: Toyota CT26 body w/ compressor bored & Turbonetics 60-1 wheel (kit)
Blitz dual solenoid boost control
Blitz blow-off valve
Greddy turbo timer
Custom down pipe & exhaust
HKS muffler plus straight pipe
ACT 6 puck clutch/Pressure Plate
JUN ultra light flywheel
KAZ Power pot LSD
Trans rebuilt inc. new syncros when diff installed
GCK axles
Tokico 5 way adj. struts
H&R springs progressive
TRD sway bars
TRD quick shift
Gauges: ECT, Volts, Fuel level, Fuel Pres, Boost, EGT, Oil temp, Oil pres.
Dash mods (gauges replace clock, volts replaced stock boost) & Pillar pod (2 gauge)

ImageUploadedByAG Free1447566045.312893.jpgImageUploadedByAG Free1447566093.631149.jpgImageUploadedByAG Free1447566128.166822.jpg

The car is really dirty but that's an easy fix. Over the last couple weeks, I've put a solid 20 hours into it- going through the wiring, vacuuming the interior, going through the engine bay, ordering a few little things like a couple small interior pieces, battery, filters and fluids. After a few hours in the engine bay, she looks like this.

ImageUploadedByAG Free1447566464.306875.jpg

Today I found the distributor cap was bad; the main contact is broken and the wire won't connect from the coil. That's now on order as well. Battery is installed, stereo works, starter works, turbo timer works, and I have fuel pressure. Going to need tires & registration before I can stretch her legs!


Sent from AutoGuide.com Free App

Last edited by Jumbosrule; November 15th, 2015 at 00:18.
Jumbosrule is offline  
Sponsored Links
Advertisement
 
post #2 of 23 (permalink) Old November 15th, 2015, 09:53
Registered User
 
Join Date: Apr 2008
Location: Thornton, Co
Posts: 573
OldTrader Rating: (6)
Congratulations!!! That is very exciting. How many miles are on the car? post more pics. Where are you at?
duckfamily is offline  
post #3 of 23 (permalink) Old November 15th, 2015, 13:20 Thread Starter
Registered User
 
Join Date: Oct 2015
Location: Redondo Beach
Posts: 29
OldTrader Rating: (0)
Garage
1991 turbo hardtop

97k miles on the clock. Less than 5000 on the built motor. I'm in the South Bay/Redondo Beach area.






Rotor cap installed and some more vacuum lines cleaned up.

I spent about two hours on the hood today. Washed, clay bar (took forever because it was in such bad shape) and two step polishing. What's there is nice but unfortunately the hood is a panel that's in the best shape on the entire car. The paint job left a lot to be desired. Terrible masking, overspray everywhere, even some runs and drips. Chipping, dents, cracking bondo... Going to take a lot of work to get it looking clean.

Last edited by Jumbosrule; March 14th, 2016 at 13:57.
Jumbosrule is offline  
Sponsored Links
Advertisement
 
post #4 of 23 (permalink) Old November 15th, 2015, 19:00
Registered User
 
Join Date: Apr 2008
Location: Thornton, Co
Posts: 573
OldTrader Rating: (6)
It looks beautiful. keep up the good work.
duckfamily is offline  
post #5 of 23 (permalink) Old November 16th, 2015, 09:55
Registered User
 
Join Date: Mar 2004
Location: West Coast
Posts: 5,026
OldTrader Rating: (5)
You're very lucky to snag one like that, and for free too. It being a project will really put the bond into you. Reminds me of my white hardtop turbo from years back, nothing like 'em.
RePete is offline  
post #6 of 23 (permalink) Old November 16th, 2015, 13:36 Thread Starter
Registered User
 
Join Date: Oct 2015
Location: Redondo Beach
Posts: 29
OldTrader Rating: (0)
Garage
Totally agree. Already bonding with the car with all the work I've already put into wiring and cleaning it up. I've bled for her already and my fingers will probably be engine bay stained for the next few weeks at least.

Got a long way to go with the paint and body. I've never had to put that much time into cleaning one single panel on the car, but the surface of the hood just had some really stubborn bonded on dirt! The horizontal surfaces are usually the worst; hood, roof and trunk usually take the most time. But all of the vertical panels are almost as bad, except they have chips, scratches, dings & dents as well. I think I need to write off the bumper - it will probably be easier to replace it and get the new one painted than it would to repair/paint what I have.

I feel like I'm close to getting her started, which will then trigger doing all the regular maintenance items for the first time. So far I've put about $400 into the car; all minor parts- a couple interior pieces, battery, battery cut-off switch, distributor, wires, fluids & filters. I know I'm going to need tires soon too.

Really looking forward to hearing it fire up for the first time. I've been dreaming about it!

Last edited by Jumbosrule; November 16th, 2015 at 14:50.
Jumbosrule is offline  
post #7 of 23 (permalink) Old November 16th, 2015, 20:15
Gold Level
 
Join Date: Jun 2005
Location: Northeast PA
Age: 49
Posts: 1,107
OldTrader Rating: (5)
Nice car w/ a lot of potential with the right owner and attitude. If ya get a chance, post up a pic of the engine bay for us.

I'm curious what kind of car those wheels are from and what size they are -- anyone?

Best of luck with the project!

PitBull
'91 Turbo | Gen4, Link ECU, PTE 5558, TCS dual exit exhaust, meth injection
'03 Spyder | Totally stock ... now and forever...


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
PitBull is offline  
post #8 of 23 (permalink) Old November 16th, 2015, 21:16 Thread Starter
Registered User
 
Join Date: Oct 2015
Location: Redondo Beach
Posts: 29
OldTrader Rating: (0)
Garage
1991 turbo hardtop

Thanks, Pitbull I appreciate it. Wheels are Toyota OE from a Celica but not sure from what year.



I snapped a couple new ones just for the request! I've been removing things to make the bay easier to clean and organize. Charcoal canister, EGR system, motor hoist bracket... And found EGR block off plates on EBay.

Replaced the HKS foam filter, cleaned up the ignition wires and installed some wire separators I had lying around.



I also pulled the trigger on a used fuse box cover for the bay. I knew there was zero chance that anything I ordered would be here today... But I was still disappointed after work when I got home and there were no packages.

Last edited by Jumbosrule; November 20th, 2015 at 18:50.
Jumbosrule is offline  
post #9 of 23 (permalink) Old November 23rd, 2015, 17:47 Thread Starter
Registered User
 
Join Date: Oct 2015
Location: Redondo Beach
Posts: 29
OldTrader Rating: (0)
Garage
The EGR block-off plates arrived and were installed 5 minutes later.



I picked up about 28" of 1/2" heater hose and used it for the manifold to intake vacuum line. My new ignition wires showed up and were the wrong part number. Amazon sent me a 6 cylinder application rather than what I ordered so now I get to deal with the return & credit. Yay.

I broke out my DMM and discovered I was not getting any voltage at the ignition coil, so I tracked it down to an intermittent short about an inch behind the coil connector. Cut out the bad wire and spliced in a 5" extension that rings out just fine on the DMM. So hopefully when my new ignition wires show up, it will be plug & play.

While I was messing around down there I unbolted the fuse/relay box, igniter & coil just to clean them off. I'll also tidy up the wire harness in that area before reinstalling it all.

Anybody want to place bets as to Start or no Start after the ignition wires arrive? I've got a good feeling. Once she starts, I'm going straight to the gas station for a fresh tank, then doing all the fluid changes. She'll get jacked up so I can take the wheels for some fresh rubber - guess that will be an early present to myself... assuming she starts!

Last edited by Jumbosrule; November 24th, 2015 at 14:54.
Jumbosrule is offline  
post #10 of 23 (permalink) Old March 14th, 2016, 13:55 Thread Starter
Registered User
 
Join Date: Oct 2015
Location: Redondo Beach
Posts: 29
OldTrader Rating: (0)
Garage
SHE LIVES.

The car started this weekend after replacing the ignition from coil through spark plugs. It took me more than two months to figure out the right parts - using the VIN and talking with dealerships got me nowhere. Right now the car will start BUT won't hold idle unless I am at WOT - so I can't take my foot off the pedal but hey - progress. It's the first time the motor has run in 2 years.

Turns out that some of the existing parts on the car were NOT correct - there was a coil installed that did not have the correct size wire contact (I think it was from a 1995 and came out of a junkyard). The wire that went from the coil to the distributor was rigged to fit by wrapping an old contact around the existing contact, then shoving that whole mess into the coil. I replaced the coil, got a new wire set, new cap and new plugs.

I removed the air intake to replace the filter and the rubber coupler at the turbo cracked and broke so now I need to repair/replace that section of the intake.

Ordered a new fuel filter and will do that install and drain the tank when the filter arrives.

Also Ordered all new vacuum hoses and several heater hoses in case anything else falls apart when I take off old rubber.
Jumbosrule is offline  
post #11 of 23 (permalink) Old March 14th, 2016, 15:55
Registered User
 
Join Date: Feb 2007
Location: CT
Age: 34
Posts: 645
OldTrader Rating: (18)
Congrats on the start up! Looks like you're headed in the right direction.
Shadow1131 is offline  
post #12 of 23 (permalink) Old March 22nd, 2016, 11:17 Thread Starter
Registered User
 
Join Date: Oct 2015
Location: Redondo Beach
Posts: 29
OldTrader Rating: (0)
Garage
Got some hours in under the car. First time it was up in the air so I did a pretty good inspection. A few disappointing finds: some leaks, cut AC lines, dents/impacts and cracking suspension bushings.

I spent time wiping down everything I could reach so I could see what was under the layer of dust/dirt. Worked my way from the front of the car to the rear.

Since I found the cut AC lines, I traced them back to the first connection fittings I could find and removed the cut lines. Not a surprise since the PO told me some of the AC parts had been removed.

Thanks to the Toyota engineers for putting a drain plug in the gas tank! How awesome is that? Made draining out the old gas pretty easy. Followed that up with a new fuel filter.

Changed the oil and the oil filter.

Changed the spark plug wires and the plugs. When I removed the old plugs, two of them came out with cracked porcelain.

Replaced a few vacuum lines with some new silicone. Unfortunately when I was removing the intake, the coupler at the turbo cracked and broke. It was heat cooked and there is no saving it. Ordered a few new silicone couplers to repair the intake and to swap the HKS mushroom foam filter for a new AEM Dryflow filter.

Next up is flushing the coolant and the brake fluid. Then new tires.

Making progress.
Jumbosrule is offline  
post #13 of 23 (permalink) Old March 22nd, 2016, 12:36
Registered User
 
Join Date: Apr 2008
Location: Thornton, Co
Posts: 573
OldTrader Rating: (6)
You should be able find any and all information needed on this site. Any chance you want to sell the car.
duckfamily is offline  
post #14 of 23 (permalink) Old March 22nd, 2016, 17:57 Thread Starter
Registered User
 
Join Date: Oct 2015
Location: Redondo Beach
Posts: 29
OldTrader Rating: (0)
Garage
1991 turbo hardtop

Well yes... Open to offers via PM.

My grand plan was to sort out the mechanicals, remove the body kit and then get a decent paint job before enjoying it for a little while, then sell it.

Not married to that plan and could be convinced to let it go at any point... If properly motivated!

Last edited by Jumbosrule; March 23rd, 2016 at 18:54.
Jumbosrule is offline  
post #15 of 23 (permalink) Old March 26th, 2016, 10:40 Thread Starter
Registered User
 
Join Date: Oct 2015
Location: Redondo Beach
Posts: 29
OldTrader Rating: (0)
Garage
1991 turbo hardtop

The parts arrived and I put together the new intake. The only OE piece I kept was the elbow. Turns out the elbow is exactly the same diameter as the turbo inlet so I kept the same diameter until just before the filter when it steps up a quarter inch. This is really a slight decrease compared to the HKS megaflow intake.

It looks good and I have some 1/2" silicone hose to replace the two rubber heater hoses connected to the two inlet ports. Love the silicone port fittings. Cool product.






Last edited by Jumbosrule; May 17th, 2016 at 12:22.
Jumbosrule is offline  
post #16 of 23 (permalink) Old March 27th, 2016, 20:48
Registered User
 
Join Date: Apr 2008
Location: Thornton, Co
Posts: 573
OldTrader Rating: (6)
Is the car running on without an AFM? I don't see it.
duckfamily is offline  
post #17 of 23 (permalink) Old March 27th, 2016, 21:46 Thread Starter
Registered User
 
Join Date: Oct 2015
Location: Redondo Beach
Posts: 29
OldTrader Rating: (0)
Garage
1991 turbo hardtop

Correct, no AFM. Eliminated when the daughter board was installed on the ECU.

Last edited by Jumbosrule; May 5th, 2016 at 00:25.
Jumbosrule is offline  
post #18 of 23 (permalink) Old May 5th, 2016, 00:17 Thread Starter
Registered User
 
Join Date: Oct 2015
Location: Redondo Beach
Posts: 29
OldTrader Rating: (0)
Garage
1991 turbo hardtop

The car is up on jack stands. After some more time with a DMM checking wiring this past weekend, it looks like two of the injectors are not firing. They have voltage, I have spark... but the spark plugs on 1 and 4 look completely new and 2 & 3 look and smell like they are seeing burn. Plan to pull the injectors and have them cleaned at RC.

While she is up in the air I have time for tires & brakes. After taking off the wheel and seeing the general condition of everything, I took advantage of my company discount and ordered all new StopTech slotted rotors, performance pads, stainless steel brake lines and a couple quarts of fluid.





Also picked up my new rubber, Nitto NT05 goodness.



Hopefully the calipers don't need any more than some lube and a flush with fresh fluid to go with new rotors, pads & braided lines.

Last edited by Jumbosrule; May 11th, 2016 at 10:27.
Jumbosrule is offline  
post #19 of 23 (permalink) Old May 30th, 2018, 12:57 Thread Starter
Registered User
 
Join Date: Oct 2015
Location: Redondo Beach
Posts: 29
OldTrader Rating: (0)
Garage
Well... I suck. The car literally sat in my garage from the date of the last post until... this past weekend. I hated putting it on the back burner but life happens and now... I'm back.

So without the time to do all this work, I just decided to flatbed the car to a shop to get all the mechanicals sorted the rest of the way.





Started with a compression test which was ok - 190, 190, 210, 210.

The fuel system had been sitting for four years so I just cut my losses and got a new Walboro fuel pump, new 550cc injectors and a new fuel filter. Flushed the tank and lines.

All the ignition parts I did last year are good to go.

The shop identified some bad pins in the main harness connector and so we replaced the connector.

The oil pan and transmission were leaking, so when the motor came out for a full timing belt and water pump job, we replaced every seal that made sense. Transmission seals all replaced, Oil pan removed and resealed, cams seals oil pump, etc.

One brake line needed to be re-flared before the brakes were buttoned up. Rotors and pads all good from last year.

Yesterday, the car started and rev'd for the first time in four years. Last year the motor turned over but wouldn't stay lit. Now she's back!



The front bumper and fenders were damaged when I got the car so I just pulled the trigger at ILOVEBODYKITS.com and got replacement fenders and a different body kit bumper. No OE stuff for me - the Kaminari stuff already on the car has been molded into the body in SOME places so I'm rationalizing the fenders and bumper to stay with the theme of the build... which is apparently rice, lol.

My goal is to just get everything mounted and straight before I decide on paint.

Last edited by Jumbosrule; May 31st, 2018 at 12:54.
Jumbosrule is offline  
post #20 of 23 (permalink) Old June 2nd, 2018, 16:51
Registered User
 
Join Date: May 2018
Posts: 14
OldTrader Rating: (0)
Nice looking car and lots of good work done by you. I like the side skirts. Do you know who they are made by?
Mathrips is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the MR2 Owners Club Message Board forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: (0 members)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome