clutch pedal squeek PERMANENT fix!!! - Page 6 - MR2 Owners Club Message Board
Reply
 
LinkBack Thread Tools
post #101 of 102 (permalink) Old November 21st, 2015, 14:32
Registered User
 
Join Date: Aug 2015
Location: Nt Kentucky
Posts: 202
OldTrader Rating: (0)
awesome posts guys, thanks indeed!!
Ajh23 is offline  
Sponsored Links
Advertisement
 
post #102 of 102 (permalink) Old November 14th, 2017, 12:01
Registered User
 
Join Date: Mar 2004
Location: Loveland, CO
Posts: 644
OldTrader Rating: (1)
I'm digging up an old thread...
I did this mod many years ago, and I noticed some "clicking" in the pedal a few months ago. I probably only have 10,000 miles on the car since the modification. I finally climbed under the dash to inspect the pedal and found my solid clevis still in tact, but I couldn't really see the bearing I installed (I remember when I drilled it out, my hole was slightly too large and the press fit was poor). I had installed a couple washers on either side of the pedal, so it wasn't really visible.

I also could not remove the pin from the clevis. I removed the pedal and was finally able to remove the pin (after much prying and twisting). It was seized, due to the fact that the bearing was completely destroyed. I'm guessing the issue arose from a poor quality bearing, rather than the less than perfect press fit, but that's speculation. I purchased the bearing at a small local hobby shop. I don't remember the brand, but I imagine it was some crap made in China.

Has anyone else had an issue of their bearing being destroyed over time? Perhaps, I simply need to purchase a higher quality bearing (Koyo or NSK)?

Quote:
Originally Posted by Gandalf View Post
Well I took so long to get around to this, I developed a different problem, at least, I hope it is (this time it's not going into 2nd gear at all, no grinding, locked out... previously it was just high RPM lockout going into 3rd)... I don't have any leaking either.
Regardless, did this mod tonight. In my case, it's pretty obvious (in my MKI.5) that the movement allowed by the clevis exacerbates the problem and wear too, so I welded solid my clevis and painted it. Nice product btw mister3, it's the right engineering call for sure.

For those drilling out the pedal for 1/2" bearing (I went with the 5/16 x 1/2 x 5/32" Teflon Sealed Bearing mentioned near the beginning of the thread), clamp the pedal down onto a 1/2" chunk of aluminum or steel on a drill press to allow the pedal bearing hole to be 100% flush, and drill using a 1/2" metal bit, but don't drill it 100% all the way through. The center of the bit will go through, but leave a microscopic lip on the one edge... this makes it easy to press in nice and snug (you can even sand it to get it a few microns tight). The bearing can't press out the far side. It's also thin enough that it's profile fits completely inside the thickness of the pedal.
By clamping the pedal down, and retracting the bit as soon as you get it drilled deep enough, it won't wear a larger than 1/2" hole.

I'll throw it back in tomorrow... I sincerely hope it's just a matter of reduced clutch stroke due to clevis buckling... somewhat worried that it only affects 2nd gear, and all others are perfect.

**Update: my issue solved itself unrelated to the bearing/clevis mods, but everything feels great. I might look at changing the spring knee-in point to make the pedal return earlier/harder.
SpdDm0n is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the MR2 Owners Club Message Board forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: (0 members)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome